summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredy García2018-12-30 13:49:15 -0500
committerFredy García2018-12-30 13:49:15 -0500
commitcbf97770d8be6992a265246587e1b8979c242b0f (patch)
treed31bf5bd135257d152c84136e87c6547b5e7e74b
parent13bc984e484230be4ecae61345b4c26de545aa93 (diff)
downloadaur-cbf97770d8be6992a265246587e1b8979c242b0f.tar.gz
Upgrading to version 0.8.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ae9f06e3a7d..ece2b0e6f528 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libssh-gnutls
pkgdesc = Library for accessing ssh client services through C libraries - compiled with gnutls (libgcrypt), documentation for libssh
- pkgver = 0.8.5
+ pkgver = 0.8.6
pkgrel = 1
url = http://www.libssh.org/
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = libssh-gnutls
makedepends = cmocka
makedepends = doxygen
makedepends = python
- source = https://www.libssh.org/files/0.8/libssh-0.8.5.tar.xz
- source = https://www.libssh.org/files/0.8/libssh-0.8.5.tar.xz.asc
+ source = https://www.libssh.org/files/0.8/libssh-0.8.6.tar.xz
+ source = https://www.libssh.org/files/0.8/libssh-0.8.6.tar.xz.asc
validpgpkeys = 8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D
- sha256sums = 07d2c431240fc88f6b06bcb36ae267f9afeedce2e32f6c42f8844b205ab5a335
+ sha256sums = 1046b95632a07fc00b1ea70ee683072d0c8a23f544f4535440b727812002fd01
sha256sums = SKIP
pkgname = libssh-gnutls
diff --git a/PKGBUILD b/PKGBUILD
index 9aa14b3b984b..03f9648d4f2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=libssh-gnutls
pkgname=(${pkgbase} ${pkgbase}-docs)
-pkgver=0.8.5
+pkgver=0.8.6
pkgrel=1
pkgdesc="Library for accessing ssh client services through C libraries - compiled with gnutls (libgcrypt), documentation for libssh"
arch=("x86_64")
@@ -10,25 +10,22 @@ url="http://www.libssh.org/"
license=("LGPL")
makedepends=("cmake" "cmocka" "doxygen" "python")
source=("https://www.libssh.org/files/${pkgver%.*}/${pkgname%-gnutls}-${pkgver}.tar.xz"{,.asc})
-sha256sums=("07d2c431240fc88f6b06bcb36ae267f9afeedce2e32f6c42f8844b205ab5a335" "SKIP")
+sha256sums=("1046b95632a07fc00b1ea70ee683072d0c8a23f544f4535440b727812002fd01" "SKIP")
validpgpkeys=("8DFF53E18F2ABC8D8F3C92237EE0FC4DCC014E3D") # Andreas Schneider <asn@cryptomilk.org>
prepare() {
cd "${srcdir}"
- # disable the test. It is confused by our clean container setup.
- # 'extra-x86-build' uses user 'nobody' that has a record in /etc/passwd file
- # but $HOME envvar is set to '/build'. The test expects that $HOME corresponds to passwd file.
- sed "s/cmocka_unit_test(torture_path_expand_tilde_unix),//" -i "libssh-${pkgver}/tests/unittests/torture_misc.c"
mkdir -p "${srcdir}/build"
}
build() {
cd "${srcdir}/build"
- cmake ../${pkgname%-gnutls}-${pkgver} \
+ cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_GSSAPI=OFF \
-DWITH_GCRYPT=ON \
- -DUNIT_TESTING=ON
+ -DUNIT_TESTING=ON \
+ "${srcdir}/${pkgname%-gnutls}-${pkgver}"
make
make docs
}