summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustKidding2022-03-05 14:03:39 -0500
committerJustKidding2022-03-05 14:03:39 -0500
commit2290978be46e2e3295368a73fb10f51c84d67303 (patch)
treefa5277fa8e24ee5b640ae2b47cb55714688b328d
parentd2e4796f2f1e9caf9f275efb6ce705dac9fad51a (diff)
downloadaur-2290978be46e2e3295368a73fb10f51c84d67303.tar.gz
upgpkg: libstdc++5 3.3.6-8
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94002fe03c73..13f9a1a32a7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = libstdc++5
pkgdesc = GNU Standard C++ library version 3
pkgver = 3.3.6
- pkgrel = 7
+ pkgrel = 8
url = https://gcc.gnu.org
arch = x86_64
license = GPL
license = LGPL
- makedepends = binutils
makedepends = gcc
+ makedepends = binutils
depends = gcc-libs
options = !makeflags
source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-3.3.6/gcc-core-3.3.6.tar.bz2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index e5a84c9ca662..8663116eb3f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: JustKidding <jk@vin.ovh>
+# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libstdc++5
pkgver=3.3.6
-pkgrel=7
+pkgrel=8
pkgdesc="GNU Standard C++ library version 3"
arch=('x86_64')
url="https://gcc.gnu.org"
license=('GPL' 'LGPL')
depends=('gcc-libs')
-makedepends=('binutils' 'gcc')
+makedepends=('gcc' 'binutils')
options=('!makeflags')
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-{core,g++}-${pkgver}.tar.bz2
gcc-3.4.3-no_multilib_amd64.patch
@@ -24,15 +25,25 @@ prepare() {
cd gcc-$pkgver
patch -Np1 -i $srcdir/gcc-3.4.3-no_multilib_amd64.patch
- patch -Np1 -i $srcdir/gcc-3.4.6-ucontext.patch
-
# fix build issue with recent gcc
sed -i "s#O_CREAT#O_CREAT, 0666#" gcc/collect2.c
# No fixincludes
- sed -i -e 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
+ sed -e 's@\./fixinc\.sh@-c true@' \
+ -e '# Clean up some warnings that arent our business' \
+ -e 's:-Wstrict-prototypes::g' \
+ -e 's:-Wtraditional::g' \
+ -e 's:-pedantic::g' \
+ -e 's:-Wall::g' \
+ -i 'gcc/Makefile.in'
+ sed -e 's:-Wall -Wtraditional -pedantic::g' -i 'libiberty/configure'
- patch -Np0 -i ../siginfo.patch
+ # Patches are the wrong way to do this
+ sed -e '# gcc-3.4.6-ucontext.patch' \
+ -e 's:\bstruct ucontext\b:ucontext_t:g' \
+ -e '# siginfo.patch' \
+ -e 's:\bstruct siginfo\b:siginfo_t:g' \
+ -i $(grep --include 'linux*.h' -lrFe $'struct ucontext\nstruct siginfo' gcc/config/)
mkdir ../gcc-build
}
@@ -46,7 +57,7 @@ build(){
CPP=/usr/bin/cpp ../gcc-${pkgver}/configure --prefix=/usr --enable-shared \
--enable-languages=c++ --enable-threads=posix --enable-__cxa_atexit \
--disable-multilib --libdir=/usr/lib
- make all-target-libstdc++-v3 BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O"
+ make all-target-libstdc++-v3 BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" -j$(nproc)
}
package() {