summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2021-05-06 01:25:59 +0200
committerFrederik Schwan2021-05-06 01:25:59 +0200
commit747ae31369a52e2d084301270bf7db94d17b229e (patch)
tree0a0acdae321b8ece9f8d10978353f24a3e798fe0
parentfcc0c7270c47c1f03679634790e6d0eeb4b512c9 (diff)
downloadaur-747ae31369a52e2d084301270bf7db94d17b229e.tar.gz
upgpkg: libstrophe-git 653.2f491e0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a34afa866d6a..3854a3d3a391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = libstrophe-git
pkgdesc = A simple, lightweight C library for writing XMPP clients
- pkgver = 273.cd92f69
+ pkgver = 653.2f491e0
pkgrel = 1
url = http://strophe.im/libstrophe/
- arch = i686
arch = x86_64
license = MIT
license = GPL3
@@ -11,11 +10,12 @@ pkgbase = libstrophe-git
makedepends = git
makedepends = doxygen
depends = expat
+ depends = openssl
provides = libstrophe
conflicts = libstrophe
options = staticlibs
source = git://github.com/strophe/libstrophe.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = libstrophe-git
diff --git a/PKGBUILD b/PKGBUILD
index 9f4a435711ac..0151e6be917e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
+# Maintainer: Frederik Schwan <freswa at archlinux dot org>
+
pkgname=libstrophe-git
-pkgver=273.cd92f69
+pkgver=653.2f491e0
pkgrel=1
-pkgdesc="A simple, lightweight C library for writing XMPP clients"
-arch=('i686' 'x86_64')
-url="http://strophe.im/libstrophe/"
+pkgdesc='A simple, lightweight C library for writing XMPP clients'
+arch=('x86_64')
+url='http://strophe.im/libstrophe/'
license=('MIT' 'GPL3')
-depends=('expat')
+depends=('expat' 'openssl')
makedepends=('git' 'doxygen')
checkdepends=('check')
provides=('libstrophe')
conflicts=('libstrophe')
-source=('git://github.com/strophe/libstrophe.git')
-sha256sums=('SKIP')
options=('staticlibs')
+source=('git://github.com/strophe/libstrophe.git')
+b2sums=('SKIP')
pkgver() {
- cd "$srcdir/libstrophe"
+ cd libstrophe
echo $(git rev-list --count master).$(git rev-parse --short master)
}
build() {
- cd "$srcdir/libstrophe"
+ cd libstrophe
./bootstrap.sh
./configure --prefix=/usr
@@ -29,11 +31,13 @@ build() {
}
check() {
- cd "$srcdir/libstrophe"
+ cd libstrophe
make check
}
package() {
- cd "$srcdir/libstrophe"
+ cd libstrophe
make DESTDIR="${pkgdir}" install
+
+ install -Dm644 -t "${pkgdir}"/usr/share/licenses/libstrophe-git/ MIT-LICENSE.txt
}