summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwout van Mansom2023-04-28 13:40:37 +0200
committerEwout van Mansom2023-04-28 13:40:37 +0200
commit131480dc6fc940ed565bc7aa0ef87dee65161d9c (patch)
tree0a70e98387c4c67670112c9fdb242049a9c26538
parentb5f086fc970bcecc671ac5f2731d671f9a235e7d (diff)
downloadaur-131480dc6fc940ed565bc7aa0ef87dee65161d9c.tar.gz
update patch again
-rw-r--r--PKGBUILD2
-rw-r--r--pr340.patch14
2 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 194716fa5fe8..5d81505c6a41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ provides=('libstumpless' 'libstumpless.so')
source=("${_projname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
'pr340.patch::https://patch-diff.githubusercontent.com/raw/goatshriek/stumpless/pull/340.patch')
sha256sums=('f3eff944d81fdf82ffe5c0df6a8c692224140c9c322ffc3ba709218a66dc07ec'
- '3805d35a70d0ae51fcef38cdf63e46ff68e2155ae2f0f045b599b4b10ecf5dc2')
+ 'e0a76a2b036fecf493a6585ead1c7ae8501818a54202125771296b5e2456aa77')
prepare() {
cd "${_projname}-${pkgver}"
diff --git a/pr340.patch b/pr340.patch
index 246395b7cae4..b9d5b89b9802 100644
--- a/pr340.patch
+++ b/pr340.patch
@@ -1,18 +1,24 @@
-From fc8646d39901b2eb2272ded9df2e7fdbfab13957 Mon Sep 17 00:00:00 2001
+From 431467bad477b8d9440ecf2a9374f69ed560a85e Mon Sep 17 00:00:00 2001
From: Ewout van Mansom <ewout@vanmansom.name>
Date: Mon, 24 Apr 2023 14:12:28 +0200
Subject: [PATCH] add pkg-config file (#339)
---
- CMakeLists.txt | 7 +++++++
+ CMakeLists.txt | 9 ++++++++-
tools/pkg-config/stumpless.pc.in | 10 ++++++++++
- 2 files changed, 17 insertions(+)
+ 2 files changed, 18 insertions(+), 1 deletion(-)
create mode 100644 tools/pkg-config/stumpless.pc.in
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c9946ce6..e51023c1 100644
+index c9946ce6..8de594ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-cmake_minimum_required(VERSION 3.2.3)
++cmake_minimum_required(VERSION 3.12)
+
+ if(POLICY CMP0135)
+ cmake_policy(SET CMP0135 NEW)
@@ -1000,6 +1000,13 @@ install(FILES
include(tools/cmake/cpack.cmake)