summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwout van Mansom2023-04-28 13:33:49 +0200
committerEwout van Mansom2023-04-28 13:33:49 +0200
commitb5f086fc970bcecc671ac5f2731d671f9a235e7d (patch)
tree5cc98b241017d1a0d777cbc0feac4af0a7f47fa1
parenteffb85cd9424a9736e5ca56621accf4178ab185c (diff)
downloadaur-b5f086fc970bcecc671ac5f2731d671f9a235e7d.tar.gz
update patch and run cmake build before tests are run
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--pr340.patch24
3 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b523377dda2..e4151ca94955 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libstumpless
pkgdesc = C logging library built for high performance and a rich feature set.
pkgver = 2.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/goatshriek/stumpless
arch = i686
arch = x86_64
@@ -17,6 +17,6 @@ pkgbase = libstumpless
source = stumpless-2.1.0.tar.gz::https://github.com/goatshriek/stumpless/archive/refs/tags/v2.1.0.tar.gz
source = pr340.patch::https://patch-diff.githubusercontent.com/raw/goatshriek/stumpless/pull/340.patch
sha256sums = f3eff944d81fdf82ffe5c0df6a8c692224140c9c322ffc3ba709218a66dc07ec
- sha256sums = 788ff6e578cea13cb39965e1309ec5cf050fead0b2834d5ed5b7aa81f6b54e15
+ sha256sums = 3805d35a70d0ae51fcef38cdf63e46ff68e2155ae2f0f045b599b4b10ecf5dc2
pkgname = libstumpless
diff --git a/PKGBUILD b/PKGBUILD
index bf5983ec4e62..194716fa5fe8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=libstumpless
_projname=stumpless
pkgver=2.1.0
-pkgrel=3
+pkgrel=4
pkgdesc='C logging library built for high performance and a rich feature set.'
arch=('i686' 'x86_64' 'aarch64')
url='https://github.com/goatshriek/stumpless'
@@ -15,7 +15,7 @@ provides=('libstumpless' 'libstumpless.so')
source=("${_projname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
'pr340.patch::https://patch-diff.githubusercontent.com/raw/goatshriek/stumpless/pull/340.patch')
sha256sums=('f3eff944d81fdf82ffe5c0df6a8c692224140c9c322ffc3ba709218a66dc07ec'
- '788ff6e578cea13cb39965e1309ec5cf050fead0b2834d5ed5b7aa81f6b54e15')
+ '3805d35a70d0ae51fcef38cdf63e46ff68e2155ae2f0f045b599b4b10ecf5dc2')
prepare() {
cd "${_projname}-${pkgver}"
@@ -33,8 +33,8 @@ build() {
}
check() {
- cd "${_projname}-${pkgver}"
- ctest --test-dir build --output-on-failure --stop-on-failure -j1
+ cmake --build "${_projname}-${pkgver}/build" --target check
+ ctest --test-dir "${_projname}-${pkgver}/build" --output-on-failure --stop-on-failure -j1
}
package() {
diff --git a/pr340.patch b/pr340.patch
index f60485134aa3..246395b7cae4 100644
--- a/pr340.patch
+++ b/pr340.patch
@@ -1,23 +1,22 @@
-From 2a1cc0a8f702db7aed1795ee064605595189e043 Mon Sep 17 00:00:00 2001
+From fc8646d39901b2eb2272ded9df2e7fdbfab13957 Mon Sep 17 00:00:00 2001
From: Ewout van Mansom <ewout@vanmansom.name>
Date: Mon, 24 Apr 2023 14:12:28 +0200
Subject: [PATCH] add pkg-config file (#339)
---
- CMakeLists.txt | 9 +++++++++
+ CMakeLists.txt | 7 +++++++
tools/pkg-config/stumpless.pc.in | 10 ++++++++++
- 2 files changed, 19 insertions(+)
+ 2 files changed, 17 insertions(+)
create mode 100644 tools/pkg-config/stumpless.pc.in
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c9946ce6..473cf2cc 100644
+index c9946ce6..e51023c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1373,6 +1373,15 @@ if(ENABLE_CPP)
- endif()
+@@ -1000,6 +1000,13 @@ install(FILES
+ include(tools/cmake/cpack.cmake)
-+# pkg-config support
+include(FindPkgConfig QUIET)
+if(PKG_CONFIG_FOUND)
+ configure_file("${PROJECT_SOURCE_DIR}/tools/pkg-config/stumpless.pc.in" "${PROJECT_BINARY_DIR}/tools/pkg-config/stumpless.pc" @ONLY)
@@ -25,13 +24,12 @@ index c9946ce6..473cf2cc 100644
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig")
+endif()
+
-+
- # python support
- if(BUILD_PYTHON)
- add_swig_project()
+
+ # functionality tests
+ add_function_test(buffer
diff --git a/tools/pkg-config/stumpless.pc.in b/tools/pkg-config/stumpless.pc.in
new file mode 100644
-index 00000000..6c92d24a
+index 00000000..d0d5b84f
--- /dev/null
+++ b/tools/pkg-config/stumpless.pc.in
@@ -0,0 +1,10 @@
@@ -42,6 +40,6 @@ index 00000000..6c92d24a
+
+Name: @CMAKE_PROJECT_NAME@
+Description: C logging library built for high performance and a rich feature set
-+Version: @CMAKE_VERSION@
++Version: @CMAKE_PROJECT_VERSION@
+Libs: -L${libdir} -lstumpless
+Cflags: -I${includedir}