summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAstroFloyd2015-07-27 18:21:10 +0200
committerAstroFloyd2015-07-27 18:21:10 +0200
commitc84999179c9db907c6fde201a3c363a5ddc0ba6e (patch)
tree3c0c6b964cfcdc6a06e8ae8db1783071e4b0b14f
downloadaur-c84999179c9db907c6fde201a3c363a5ddc0ba6e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--ChangeLog19
-rw-r--r--PKGBUILD32
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..107ac2c8a5a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libsufr
+ pkgdesc = A LIBrary containing Some Useful Fortran Routines
+ pkgver = 0.6.5
+ pkgrel = 1
+ url = http://libsufr.sourceforge.net/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = gcc-fortran
+ depends = gcc-libs
+ source = http://sourceforge.net/projects/libsufr/files/libsufr-0.6.5.tar.gz
+ sha512sums = 748b7200d36be19763eea830ca57a530a1dc2b17e1ae988c76b1028fe13e4522cef13b47a38a24b5e6428d6b37d2d5a77b091eb3ce51a33fe92a2703a8ec7204
+
+pkgname = libsufr
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..635db7a2017b
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,19 @@
+
+ChangeLog for libSUFR PKGBUILD
+http://libsufr.sourceforge.net/
+
+* libsufr-0.6.5-1 (2015-05-23 - AstroFloyd)
+ Version bump to v0.6.5
+
+* libsufr-0.6.4-1 (2015-05-09 - AstroFloyd)
+ Version bump to v0.6.4
+
+* libsufr-0.6.3-2 (2015-04-28 - AstroFloyd)
+ Added cmake as a make dependency
+
+* libsufr-0.6.3-1 (2015-04-26 - AstroFloyd)
+ Version bump to v0.6.3
+
+* libsufr-0.6.2-1 (2015-01-17 - AstroFloyd)
+ Initial PKGBUILD for libSUFR v0.6.2, to be uploaded to AUR
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4039d189bdf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: AstroFloyd < AstroFloyd [at] gmail [dt] com >
+pkgname=libsufr
+pkgver=0.6.5
+pkgrel=1
+pkgdesc="A LIBrary containing Some Useful Fortran Routines"
+arch=('i686' 'x86_64')
+url="http://libsufr.sourceforge.net/"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('cmake' 'gcc-fortran')
+changelog=ChangeLog
+source=("http://sourceforge.net/projects/libsufr/files/$pkgname-$pkgver.tar.gz")
+sha512sums=('748b7200d36be19763eea830ca57a530a1dc2b17e1ae988c76b1028fe13e4522cef13b47a38a24b5e6428d6b37d2d5a77b091eb3ce51a33fe92a2703a8ec7204')
+
+build() {
+ mkdir -p "$pkgname-$pkgver"/build
+ cd "$pkgname-$pkgver"/build/
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr/" ..
+ make
+}
+
+package() {
+ # Install library:
+ cd "$pkgname-$pkgver"/build/
+ make install
+
+ # Install man pages:
+ mkdir -p ${pkgdir}/usr/share/man/man3/
+ cd ../man/
+ gzip -9 *
+ cp * ${pkgdir}/usr/share/man/man3/
+}