summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Pohl2023-07-21 15:55:43 +0200
committerAlexander Pohl2023-07-21 15:55:43 +0200
commitfc484fa5f7676747610fd1327da8f39f1c80e5dc (patch)
tree2c60f12c45e79487272440e1a977166a456da83c
downloadaur-fc484fa5f7676747610fd1327da8f39f1c80e5dc.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cdb45c9c274
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libsunspec
+ pkgdesc = A C++ library for SunSpec compatible inverters, meters and batteries
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://ahpohl.github.io/libsunspec/
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ depends = libmodbus
+ source = libsunspec-0.1.0::git+https://github.com/ahpohl/libsunspec.git#tag=v0.1.0
+ sha256sums = SKIP
+
+pkgname = libsunspec
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d3c42f488b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alexander Pohl <alex at ahpohl dot com>
+pkgname=libsunspec
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="A C++ library for SunSpec compatible inverters, meters and batteries"
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
+url="https://ahpohl.github.io/libsunspec/"
+license=('GPL3')
+groups=()
+depends=('libmodbus')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+https://github.com/ahpohl/libsunspec.git#tag=v${pkgver}")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+ install -Dm644 CHANGELOG.md "$pkgdir"/usr/share/doc/$pkgname/CHANGELOG.md
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -d "$pkgdir"/usr/include/$pkgname
+ install -Dm644 include/* "$pkgdir"/usr/include/$pkgname
+}