summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2022-10-20 20:15:13 +0200
committerChristoph Haag2022-10-20 20:15:13 +0200
commit24084fc2cd111a486272a07a4c046bb30ae77737 (patch)
treec4580a4234694f3f48c620fefcf0bf35dff4a749
parenteea13eb4d4e2b02ec07f14cece17aa2e80abfa03 (diff)
downloadaur-24084fc2cd111a486272a07a4c046bb30ae77737.tar.gz
Set submodule urls and allow file protocol
https://bugs.archlinux.org/task/76255
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cc4735432b2..376c9ebc0a62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
basename=libsurvive
pkgname=$basename-git
-pkgver=2207.d939c24
+pkgver=2216.5319743
pkgrel=1
pkgdesc="Open-Source tool for working with lighthouse-based tracking data, including support for the HTC Vive, Vive Pro and Valve Index."
arch=(x86_64 i686)
@@ -12,7 +12,7 @@ provides=($basename)
makedepends=("git" "cmake" "ninja")
source=($basename::"git+https://github.com/cntools/libsurvive.git"
cnkalman.git::"git+https://github.com/cntools/cnkalman.git"
- cnmatrix.git::"git+https://github.com/cntools/cnmatrix.git")
+ cnmatrix.git::"git+https://github.com/cntools/cnmatrix.git")
sha256sums=('SKIP'
'SKIP'
'SKIP')
@@ -26,7 +26,19 @@ pkgver() {
prepare() {
cd $basename
- git submodule update --init --recursive
+
+ # https://bugs.archlinux.org/task/76255
+ git submodule set-url libs/cnkalman "$srcdir/cnkalman.git"
+ # avoided security issue by setting submodule url
+ git -c protocol.file.allow=always submodule update --init
+
+ cd libs/cnkalman
+ git submodule set-url libs/cnmatrix "$srcdir/cnmatrix.git"
+ # avoided security issue by setting submodule url
+ git -c protocol.file.allow=always submodule update --init
+
+ cd "$srcdir"/$basename
+
sed "s!cnmatrix/matrix.h!cnmatrix/cn_matrix.h!g" -i tools/vive_mouse/vive_mouse.c
git revert --no-commit 84423daf44b430f8ec12e7650f46027070d7df73
}