summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2022-02-03 11:29:23 +0100
committerChristoph Haag2022-02-03 11:29:23 +0100
commitdf8f9ea99812d09a89f951e30b3bd1cb241c5b70 (patch)
tree1357ffe13f950ee0e16c975249bceaef6dad10ee
parent4862c89b2b2cd90e8a143f9bc4bb70b56e2113dc (diff)
downloadaur-df8f9ea99812d09a89f951e30b3bd1cb241c5b70.tar.gz
remove unset CFLAGS hack and add CMAKE_BUILD_TYPE=Release
the missing controller thing was fixed in https://github.com/cntools/libsurvive/commit/30f5b7bb8506342431d0ceaa8fd14c51a3c0da86
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22af58af330e..de345dd559b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
basename=libsurvive
pkgname=$basename-git
-pkgver=2023.feca145
+pkgver=2109.30f5b7b
pkgrel=1
pkgdesc="Open-Source tool for working with lighthouse-based tracking data, including support for the HTC Vive, Vive Pro and Valve Index."
arch=(x86_64 i686)
@@ -31,9 +31,6 @@ prepare() {
}
build() {
- # HACK: possible issue with -O flags and second index controller not being detected, seems to be better with only survive's own cflags
- unset CFLAGS CXXFLAG
-
cd $basename
rm -rf build
@@ -43,7 +40,7 @@ build() {
# This will probably require slightly more cpu power than a tuned blas implementation.
# If running on a weak CPU, consider installing a blas implementation and using -DUSE_EIGEN=OFF.
- cmake -B build -G Ninja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_EIGEN=ON
+ cmake -B build -G Ninja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_EIGEN=ON -DCMAKE_BUILD_TYPE=Release
ninja -C build
}