summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Di Luigi2015-09-21 23:16:16 +0200
committerWilliam Di Luigi2015-09-21 23:16:16 +0200
commite38bdcf55d3ffbe1168f15d3a6ca8a021188cbfc (patch)
tree4fd333ea82f3b16ec86f4b3a2064bfc615dd6dd8
downloadaur-e38bdcf55d3ffbe1168f15d3a6ca8a021188cbfc.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff204e8a6ec6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Mon Sep 21 21:15:59 UTC 2015
+pkgbase = libt3key
+ pkgdesc = Terminal key sequence database library.
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = http://os.ghalkes.nl/t3/libt3key.html
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = libt3config>=0.2.5
+ depends = libxcb
+ options = !libtool
+ source = http://os.ghalkes.nl/dist/libt3key-0.2.6.tar.bz2
+ md5sums = 6701cfe84a05f823f9760c17e433f9ae
+
+pkgname = libt3key
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..984541f8f887
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gertjan Halkes <arch at ghalkes dot nl>
+pkgname=libt3key
+pkgver=0.2.6
+pkgrel=1
+pkgdesc="Terminal key sequence database library."
+arch=('x86_64' 'i686')
+url="http://os.ghalkes.nl/t3/$pkgname.html"
+license=('GPL3')
+groups=()
+depends=('libt3config>=0.2.5' 'libxcb')
+makedepends=()
+optdepends=()
+conflicts=()
+replaces=()
+backup=()
+options=('!libtool')
+install=''
+changelog=
+source=("http://os.ghalkes.nl/dist/$pkgname-$pkgver.tar.bz2")
+noextract=()
+md5sums=('6701cfe84a05f823f9760c17e433f9ae')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr CFLAGS="-O2 -D_POSIX_C_SOURCE=200809L"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/share/doc/$pkgname/API"
+}