summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGertjan Halkes2018-12-06 09:06:32 +0000
committerGertjan Halkes2018-12-06 09:06:32 +0000
commit1b209c5ba4e753aaaf4935353e25641a68f7ad60 (patch)
treef6e3f5b27890efbc2499d2ca7a7a6989c35ef43e
parent106e9eebe252d2c7cdb97e3f16e664a91f42098d (diff)
downloadaur-1b209c5ba4e753aaaf4935353e25641a68f7ad60.tar.gz
Updated to version 1.0.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b43e8494e9d..7fc6822aeec7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
-# Generated by makepkg 5.0.0
-# Tue Feb 23 14:34:57 UTC 2016
pkgbase = libt3widget
pkgdesc = A C++ terminal dialog toolkit.
- pkgver = 0.5.2
+ pkgver = 1.0.2
pkgrel = 1
url = http://os.ghalkes.nl/t3/libt3widget.html
arch = x86_64
arch = i686
license = GPL3
makedepends = libxcb
+ depends = libtranscript>=0.2.2
depends = libt3key>=0.2.0
- depends = libt3window>=0.2.1
+ depends = libt3window>=0.3.1
depends = libsigc++
depends = gpm
+ depends = pcre
optdepends = libxcb: for integration with the X11 clipboard
options = !libtool
- source = http://os.ghalkes.nl/dist/libt3widget-0.5.2.tar.bz2
- md5sums = d7de19979df76a1f450c7218f964355d
+ source = http://os.ghalkes.nl/dist/libt3widget-1.0.2.tar.bz2
+ md5sums = 156a041e324ddf54f0b70d6dbcafacb6
pkgname = libt3widget
diff --git a/PKGBUILD b/PKGBUILD
index 540029971ed0..f7d3cd1509e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: William Di Luigi <williamdiluigi@gmail.com>
pkgname=libt3widget
-pkgver=0.5.2
+pkgver=1.0.2
pkgrel=1
pkgdesc="A C++ terminal dialog toolkit."
arch=('x86_64' 'i686')
url="http://os.ghalkes.nl/t3/$pkgname.html"
license=('GPL3')
groups=()
-depends=('libt3key>=0.2.0' 'libt3window>=0.2.1' 'libsigc++' 'gpm')
+depends=('libtranscript>=0.2.2' 'libt3key>=0.2.0' 'libt3window>=0.3.1' 'libsigc++' 'gpm' 'pcre')
makedepends=('libxcb')
optdepends=('libxcb: for integration with the X11 clipboard')
conflicts=()
@@ -20,16 +20,15 @@ install=''
changelog=
source=("http://os.ghalkes.nl/dist/$pkgname-$pkgver.tar.bz2")
noextract=()
-md5sums=('d7de19979df76a1f450c7218f964355d')
+md5sums=('156a041e324ddf54f0b70d6dbcafacb6')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- CXXFLAGS="-O2 -std=c++11" ./configure --prefix=/usr
+ ./configure --prefix=/usr
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}/usr/share/doc/$pkgname/API"
}