summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Di Luigi2015-09-21 23:12:07 +0200
committerWilliam Di Luigi2015-09-21 23:12:07 +0200
commit364f046132456ccfd69ebddcb5dc58fb6980fe21 (patch)
tree731506b2142ab5e451fffe344e4813acff92299b
downloadaur-364f046132456ccfd69ebddcb5dc58fb6980fe21.tar.gz
First commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9983f726d765
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Mon Sep 21 21:11:28 UTC 2015
+pkgbase = libt3widget
+ pkgdesc = A C++ terminal dialog toolkit.
+ pkgver = 0.4.7
+ pkgrel = 1
+ url = http://os.ghalkes.nl/t3/libt3widget.html
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = libxcb
+ depends = libt3key>=0.2.0
+ depends = libt3window>=0.2.1
+ depends = libsigc++
+ depends = gpm
+ optdepends = libxcb: for integration with the X11 clipboard
+ options = !libtool
+ source = http://os.ghalkes.nl/dist/libt3widget-0.4.7.tar.bz2
+ md5sums = 530a1f8bd912800f5cebcfb8801998eb
+
+pkgname = libt3widget
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3cb6ddc279a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gertjan Halkes <arch at ghalkes dot nl>
+pkgname=libt3widget
+pkgver=0.4.7
+pkgrel=1
+pkgdesc="A C++ terminal dialog toolkit."
+arch=('x86_64' 'i686')
+url="http://os.ghalkes.nl/t3/$pkgname.html"
+license=('GPL3')
+groups=()
+depends=('libt3key>=0.2.0' 'libt3window>=0.2.1' 'libsigc++' 'gpm')
+makedepends=('libxcb')
+optdepends=('libxcb: for integration with the X11 clipboard')
+conflicts=()
+replaces=()
+backup=()
+options=('!libtool')
+install=''
+changelog=
+source=("http://os.ghalkes.nl/dist/$pkgname-$pkgver.tar.bz2")
+noextract=()
+md5sums=('530a1f8bd912800f5cebcfb8801998eb')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/share/doc/$pkgname/API"
+}