summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorw568w2024-01-29 14:22:06 +0800
committerw568w2024-01-29 14:22:06 +0800
commite0e06b3cd53ba940a5833ba89069f0d762a0400b (patch)
tree05a171849605422eb919bafefc93b6d4abd3bc7a
downloadaur-e0e06b3cd53ba940a5833ba89069f0d762a0400b.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
-rw-r--r--libtar-twrp.install3
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db2e41530d20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libtar-twrp-git
+ pkgdesc = C library for manipulating POSIX tar files (Patched with TWRP Backup Format Support)
+ pkgver = r53.7f86978
+ pkgrel = 1
+ url = https://github.com/simon816/libtar-twrp
+ install = libtar-twrp.install
+ arch = x86_64
+ arch = aarch64
+ license = BSD
+ makedepends = git
+ makedepends = libselinux
+ makedepends = autoconf
+ depends = zlib
+ depends = glibc
+ depends = libselinux
+ provides = libtar-twrp
+ conflicts = libtar-twrp
+ options = libtool
+ source = libtar-twrp::git+https://github.com/simon816/libtar-twrp.git#branch=master
+ sha256sums = SKIP
+
+pkgname = libtar-twrp-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..561eb2b2acd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: w568w <w568w at outlook dot com>
+pkgname=libtar-twrp-git
+_pkgname="libtar-twrp"
+pkgver=r53.7f86978
+pkgrel=1
+pkgdesc="C library for manipulating POSIX tar files (Patched with TWRP Backup Format Support)"
+arch=('x86_64' 'aarch64')
+url="https://github.com/simon816/libtar-twrp"
+license=('BSD')
+options=('libtool')
+depends=('zlib' 'glibc' 'libselinux')
+makedepends=('git' 'libselinux' 'autoconf')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+install=libtar-twrp.install
+source=("${_pkgname}::git+https://github.com/simon816/libtar-twrp.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ if [[ $LDFLAGS == *"-fuse-ld=mold"* ]]; then
+ echo "=== !!!WARNING!!! ==="
+ echo "You are using mold linker, which may cause broken binary."
+ echo "The build process will continue, but the binary may NOT work."
+ echo "If you encounter any problem, please try to use original linker."
+ echo "=== !!!WARNING!!! ==="
+ fi
+ autoreconf --force --install
+ ./configure --prefix=/opt/libtar-twrp
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/libtar-twrp.install b/libtar-twrp.install
new file mode 100644
index 000000000000..c9ce13bd01e4
--- /dev/null
+++ b/libtar-twrp.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "You can run the libtar executable in /opt/libtar-twrp/bin, e.g. /opt/libtar-twrp/bin/libtar --help"
+} \ No newline at end of file