summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinston Weinert2017-04-06 03:01:58 -0500
committerWinston Weinert2017-04-06 03:01:58 -0500
commitea3f34e1ef8a42eefb43e6dbbac5a28f54266033 (patch)
tree0e1c6b33902625ca5fb2fb8e67b1cbf412be8e91
parent82517c5b2c7d3ec6dec8fd3b6530bea81b5f7f47 (diff)
downloadaur-ea3f34e1ef8a42eefb43e6dbbac5a28f54266033.tar.gz
Revert back to 1.5.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd35c58d0c08..4c5433e9771b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = libtcod
pkgdesc = Roguelike graphics/utility library
- pkgver = 1.6.3
- pkgrel = 1
+ pkgver = 1.5.1
+ pkgrel = 6
url = https://bitbucket.org/libtcod/libtcod
arch = i686
arch = x86_64
license = BSD
makedepends = mercurial
- depends = sdl2
- source = hg+https://bitbucket.org/libtcod/libtcod#tag=1.6.3
+ depends = libpng
+ depends = sdl
+ depends = glu
+ options = !makeflags
+ source = hg+https://bitbucket.org/libtcod/libtcod#tag=1.5.1
md5sums = SKIP
pkgname = libtcod
diff --git a/PKGBUILD b/PKGBUILD
index 87cf69462a8c..6cbc295b9015 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,36 @@
# Contributor: SirClueless
pkgname=libtcod
-pkgver=1.6.3
-pkgrel=1
+pkgver=1.5.1
+pkgrel=6
pkgdesc="Roguelike graphics/utility library"
arch=('i686' 'x86_64')
url="https://bitbucket.org/libtcod/libtcod"
license=('BSD')
-depends=('sdl2')
+depends=('libpng' 'sdl' 'glu')
makedepends=('mercurial')
+options=(!makeflags)
source=("hg+https://bitbucket.org/$pkgname/$pkgname#tag=$pkgver")
md5sums=('SKIP')
build() {
- cd "$srcdir/$pkgname/build/autotools"
- autoreconf -i
- ./configure --prefix=/usr
- make
+ cd "$srcdir/$pkgname"
+
+ if test "$CARCH" == x86_64; then
+ make -f makefiles/makefile-linux64 clean release TEMP=$srcdir/tmp
+ else
+ make -f makefiles/makefile-linux clean release TEMP=$srcdir/tmp
+ fi
}
package() {
- cd "$srcdir/$pkgname/build/autotools"
- make DESTDIR="$pkgdir" install
+ mkdir -p $pkgdir/usr/lib
+ mkdir -p $pkgdir/usr/include/$pkgname
+
+ cd "$srcdir/$pkgname"
- mkdir -p "$pkgdir/usr/share/licenses/libtcod"
- cp "$srcdir/$pkgname/LIBTCOD-LICENSE.txt" "$pkgdir/usr/share/licenses/libtcod"
+ install -D -m 644 libtcod{,gui,xx}.so $pkgdir/usr/lib/
+ install -D -m 644 include/*.h* $pkgdir/usr/include/$pkgname/
}
# vim:set ts=2 sw=2 et: