summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-05-13 20:27:01 -0600
committergustawho2021-05-13 20:27:01 -0600
commit5a49123bb7059c3d633ba53f054c37c6cf95743e (patch)
tree689e8981d2085a66c91b6477fb18d2012dfa3665
parent22a747810b4a4fcfae1f1d40f9aa43352eb5b028 (diff)
downloadaur-5a49123bb7059c3d633ba53f054c37c6cf95743e.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a02164132724..462045b111d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libtd-git
pkgdesc = TDLib (Telegram Database library) is a cross-platform library for building Telegram clients (Git)
- pkgver = 1.7.0.r747.gb342ec33
+ pkgver = 1.7.0.r760.g445183e5
pkgrel = 1
url = https://core.telegram.org/tdlib
arch = x86_64
@@ -14,7 +14,6 @@ pkgbase = libtd-git
makedepends = make
makedepends = cmake
makedepends = gperf
- makedepends = php
depends = openssl
depends = zlib
provides = libtd
diff --git a/PKGBUILD b/PKGBUILD
index 31190d574d67..1f1fb3cf0c2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Previous Contributor: Felix Serrano Blanco <felixseblanc@gmail.com>
pkgname=libtd-git
-pkgver=1.7.0.r747.gb342ec33
+pkgver=1.7.0.r760.g445183e5
pkgrel=1
pkgdesc='TDLib (Telegram Database library) is a cross-platform library for building Telegram clients (Git)'
arch=('x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url='https://core.telegram.org/tdlib'
license=('Boost')
depends=('openssl' 'zlib')
-makedepends=('git' 'gcc' 'make' 'cmake' 'gperf' 'php')
+makedepends=('git' 'gcc' 'make' 'cmake' 'gperf')
provides=('libtd')
conflicts=('telegram-tdlib' 'libtd')
source=("${pkgname%-git}::git+https://github.com/tdlib/td.git")
@@ -22,10 +22,10 @@ pkgver() {
}
build() {
- cmake -B build -S "${pkgname%-git}" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
- cmake --build build --config Release
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- DESTDIR="${pkgdir}" cmake --install build --config Release
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file