summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicholas Wang2018-07-06 01:28:05 +0800
committerNicholas Wang2018-07-06 01:28:05 +0800
commit9118e4ab0f11cd5c9b8221d1a02300de9305db2b (patch)
tree30074d65dc36fabe4131d232ba9f9274b99c8156
downloadaur-9118e4ab0f11cd5c9b8221d1a02300de9305db2b.tar.gz
Initial commit, without testing.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
-rw-r--r--shared.patch7
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ca089a3a1b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libtgbot-cpp-git
+ pkgdesc = C++ library for Telegram bot API.
+ pkgver = r218.7f38839
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/reo7sp/tgbot-cpp
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ depends = glibc
+ depends = openssl
+ depends = boost-libs
+ depends = gcc-libs
+ replaces = libtgbot-cpp
+ source = tgbot-cpp::git+https://github.com/reo7sp/tgbot-cpp.git#branch=master
+ md5sums = SKIP
+
+pkgname = libtgbot-cpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e81b5000b638
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Nicholas Wang <wck963@gmail.com>
+
+pkgname=libtgbot-cpp-git
+pkgver=r218.7f38839
+pkgrel=1
+pkgdesc="C++ library for Telegram bot API."
+arch=('x86_64')
+url="https://github.com/reo7sp/tgbot-cpp"
+license=('MIT')
+depends=('glibc' 'openssl' 'boost-libs' 'gcc-libs')
+makedepends=('boost')
+replaces=("libtgbot-cpp")
+source=('tgbot-cpp::git+https://github.com/reo7sp/tgbot-cpp.git#branch=master')
+md5sums=('SKIP')
+epoch=1
+
+pkgver() {
+ cd tgbot-cpp
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$srcdir/tgbot-cpp"
+ patch -p1 -i "$srcdir/shared.patch"
+}
+
+build() {
+ cd "$srcdir/tgbot-cpp"
+ cmake .
+ make -j4
+}
+
+package() {
+ cd "$srcdir/tgbot-cpp"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/shared.patch b/shared.patch
new file mode 100644
index 000000000000..8eeb96496215
--- /dev/null
+++ b/shared.patch
@@ -0,0 +1,7 @@
+--- CMakeLists.txt 2018-07-06 01:14:01.114978618 +0800
++++ CMakeLists.txt 2018-07-06 01:14:25.542122689 +0800
+@@ -5,3 +5,3 @@
+ option(ENABLE_TESTS "Set to ON to enable building of tests" OFF)
+-option(BUILD_SHARED_LIBS "Build tgbot-cpp shared/static library." OFF)
++option(BUILD_SHARED_LIBS "Build tgbot-cpp shared/static library." ON)
+