summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicholas Wang2018-07-06 02:14:52 +0800
committerNicholas Wang2018-07-06 02:14:52 +0800
commit9ea6e38efc1b6c7cefda2096f408b85724e05fe2 (patch)
tree39b1af30d0425cee685342a7080300dcc41073de
parent9118e4ab0f11cd5c9b8221d1a02300de9305db2b (diff)
downloadaur-9ea6e38efc1b6c7cefda2096f408b85724e05fe2.tar.gz
tested version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ca089a3a1b2..4b820257215c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = libtgbot-cpp-git
pkgdesc = C++ library for Telegram bot API.
pkgver = r218.7f38839
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/reo7sp/tgbot-cpp
arch = x86_64
license = MIT
makedepends = boost
- depends = glibc
depends = openssl
depends = boost-libs
- depends = gcc-libs
replaces = libtgbot-cpp
source = tgbot-cpp::git+https://github.com/reo7sp/tgbot-cpp.git#branch=master
+ source = shared.patch
md5sums = SKIP
+ md5sums = edfaaac5acf67c4c8f5c1cb7e8c351a8
pkgname = libtgbot-cpp-git
diff --git a/PKGBUILD b/PKGBUILD
index e81b5000b638..c9f5c7351389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,18 @@
pkgname=libtgbot-cpp-git
pkgver=r218.7f38839
-pkgrel=1
+pkgrel=2
pkgdesc="C++ library for Telegram bot API."
arch=('x86_64')
url="https://github.com/reo7sp/tgbot-cpp"
license=('MIT')
-depends=('glibc' 'openssl' 'boost-libs' 'gcc-libs')
+depends=('openssl' 'boost-libs')
makedepends=('boost')
replaces=("libtgbot-cpp")
-source=('tgbot-cpp::git+https://github.com/reo7sp/tgbot-cpp.git#branch=master')
-md5sums=('SKIP')
+source=('tgbot-cpp::git+https://github.com/reo7sp/tgbot-cpp.git#branch=master'
+ 'shared.patch')
+md5sums=('SKIP'
+ 'edfaaac5acf67c4c8f5c1cb7e8c351a8')
epoch=1
pkgver() {
@@ -24,7 +26,7 @@ pkgver() {
prepare() {
cd "$srcdir/tgbot-cpp"
- patch -p1 -i "$srcdir/shared.patch"
+ patch -p0 -i "$srcdir/shared.patch"
}
build() {
@@ -36,4 +38,7 @@ build() {
package() {
cd "$srcdir/tgbot-cpp"
make DESTDIR="$pkgdir/" install
+ mv "$pkgdir/usr/local/"* "$pkgdir/usr"
+ rmdir "$pkgdir/usr/local"
+ install -Dm644 "$srcdir/tgbot-cpp/LICENSE" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}