summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Fedin2020-01-06 13:14:37 +0400
committerIlya Fedin2020-01-06 13:14:37 +0400
commit69e7628c78faf888f1b8bcc8ae5fa5729283ee09 (patch)
treee4b3f22dae083ba4de257784eed44801170745f5
parentd249f49989e33b0e49af99f5ffec6d7088cdd346 (diff)
downloadaur-69e7628c78faf888f1b8bcc8ae5fa5729283ee09.tar.gz
Update to 88b47b6 and add a pkg-config path
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--libtgvoip-use-pkgconfig.patch49
3 files changed, 68 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3bf9a57f056..bb2547f6c97d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libtgvoip
pkgdesc = VoIP library for Telegram clients
pkgver = 2.4.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/telegramdesktop/libtgvoip
arch = x86_64
license = Unlicense
@@ -9,8 +9,10 @@ pkgbase = libtgvoip
depends = opus
optdepends = alsa-lib: for alsa support
optdepends = libpulse: for pulseaudio support
- source = https://github.com/telegramdesktop/libtgvoip/archive/303dcacc2ad0428fd165c71455056d3f8f884d6f.zip
- sha512sums = f369a99fc8cc39a6b62c81fa8513bfe187d3c91a747cd12fee0dfddec6ef26eac6c24b124e4212304796e679286cf5eaa303a731620a08e230a5f0ded71857b9
+ source = https://github.com/telegramdesktop/libtgvoip/archive/88b47b6f808f2573d4eaf37e1463ecd59c43deda.zip
+ source = libtgvoip-use-pkgconfig.patch
+ sha512sums = 38dc34d6ce197d7dfaf06b5bef305fb7099586c14aa2a0142f0cd0f6bca2fdd96e23be22f00ae195a7e89e08c2a6a6f36c1a618e8e4eeb50a507f266c1b4ae21
+ sha512sums = 70b97446c5bb89cf6b6d2ebfb43ad88172d7e41481b4cd2ad6fd800b403bb432b1e68d022141e288c556046e5bd8c802788c6d69ac242cbc90d900d76ac8ae74
pkgname = libtgvoip
diff --git a/PKGBUILD b/PKGBUILD
index e32a6e190711..21a3d0820563 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libtgvoip
pkgver=2.4.4
-pkgrel=2
+pkgrel=3
pkgdesc="VoIP library for Telegram clients"
arch=(x86_64)
url="https://github.com/telegramdesktop/libtgvoip"
@@ -12,13 +12,23 @@ optdepends=(
'alsa-lib: for alsa support'
'libpulse: for pulseaudio support'
)
-_commit="303dcacc2ad0428fd165c71455056d3f8f884d6f"
-source=("https://github.com/telegramdesktop/libtgvoip/archive/${_commit}.zip")
+_commit="88b47b6f808f2573d4eaf37e1463ecd59c43deda"
+source=(
+ "https://github.com/telegramdesktop/libtgvoip/archive/${_commit}.zip"
+ "libtgvoip-use-pkgconfig.patch"
+)
+
+sha512sums=('38dc34d6ce197d7dfaf06b5bef305fb7099586c14aa2a0142f0cd0f6bca2fdd96e23be22f00ae195a7e89e08c2a6a6f36c1a618e8e4eeb50a507f266c1b4ae21'
+ '70b97446c5bb89cf6b6d2ebfb43ad88172d7e41481b4cd2ad6fd800b403bb432b1e68d022141e288c556046e5bd8c802788c6d69ac242cbc90d900d76ac8ae74')
-sha512sums=('f369a99fc8cc39a6b62c81fa8513bfe187d3c91a747cd12fee0dfddec6ef26eac6c24b124e4212304796e679286cf5eaa303a731620a08e230a5f0ded71857b9')
+prepare() {
+ cd "$srcdir/$pkgname-${_commit}"
+ patch -Np1 -i "$srcdir/libtgvoip-use-pkgconfig.patch"
+}
build() {
cd "$srcdir/$pkgname-${_commit}"
+ autoreconf -i
./configure --prefix=/usr
make
}
diff --git a/libtgvoip-use-pkgconfig.patch b/libtgvoip-use-pkgconfig.patch
new file mode 100644
index 000000000000..814821538ff1
--- /dev/null
+++ b/libtgvoip-use-pkgconfig.patch
@@ -0,0 +1,49 @@
+diff --git a/Makefile.am b/Makefile.am
+index 03c8866..a9c9715 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -755,6 +755,8 @@ libtgvoip_la_SOURCES = $(SRC) $(TGVOIP_HDRS)
+ tgvoipincludedir = $(includedir)/tgvoip
+ nobase_tgvoipinclude_HEADERS = $(TGVOIP_HDRS)
+
++pkgconfig_DATA = tgvoip.pc
++
+ CXXFLAGS += -std=gnu++0x $(CFLAGS)
+ if TARGET_OS_OSX
+ OBJCFLAGS = $(CFLAGS)
+diff --git a/configure.ac b/configure.ac
+index 222f541..e2df927 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,6 +9,8 @@ AM_INIT_AUTOMAKE([subdir-objects])
+ AM_SILENT_RULES([yes])
+ LT_INIT
+
++PKG_INSTALLDIR
++
+ # Checks for programs.
+ AC_PROG_CXX
+ AC_PROG_CC
+@@ -109,5 +111,5 @@ AC_FUNC_MALLOC
+ AC_FUNC_REALLOC
+ AC_CHECK_FUNCS([clock_gettime floor gettimeofday inet_ntoa memmove memset select socket sqrt strcasecmp strchr strerror strncasecmp strstr strtol strtoul uname])
+
+-AC_CONFIG_FILES([Makefile])
++AC_CONFIG_FILES([Makefile tgvoip.pc])
+ AC_OUTPUT
+diff --git a/tgvoip.pc.in b/tgvoip.pc.in
+new file mode 100644
+index 0000000..1ca7758
+--- /dev/null
++++ b/tgvoip.pc.in
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: tgvoip
++Description: VoIP library for Telegram clients
++Version: 2.4.4
++Libs: -L${libdir} -ltgvoip
++Cflags: -I${includedir}/tgvoip