summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMykyta Poturai2021-09-19 13:31:09 +0300
committerMykyta Poturai2021-09-19 13:31:09 +0300
commit0e8e70880a97401efee4bd063ab5227eaaf84b24 (patch)
tree5b138378bc4c7ea61ac1eca0d665a0cf9610b0e0
downloadaur-0e8e70880a97401efee4bd063ab5227eaaf84b24.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
-rw-r--r--makefile-ldconfig.patch14
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddab191136aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libthemis
+ pkgdesc = Open-source high-level cryptographic services library.
+ pkgver = 0.13.12
+ pkgrel = 1
+ url = https://github.com/cossacklabs/themis
+ arch = x86_64
+ license = Apache
+ makedepends = make
+ makedepends = gcc
+ depends = openssl
+ source = https://github.com/cossacklabs/themis/archive/refs/tags/0.13.12.tar.gz
+ source = makefile-ldconfig.patch
+ md5sums = 22e68c9a28f27f008fbadb3ea927abef
+ md5sums = 5d5db18b2d72d7db21cd7f9d701c2221
+
+pkgname = libthemis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbb834f0478f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Mykyta Poturai <mykyta.poturai@tutanota.com>
+pkgname=libthemis
+pkgver=0.13.12
+pkgrel=1
+pkgdesc="Open-source high-level cryptographic services library."
+url="https://github.com/cossacklabs/themis"
+arch=('x86_64')
+license=('Apache')
+depends=('openssl')
+makedepends=('make' 'gcc')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/cossacklabs/themis/archive/refs/tags/$pkgver.tar.gz"
+ "makefile-ldconfig.patch")
+md5sums=('22e68c9a28f27f008fbadb3ea927abef'
+ '5d5db18b2d72d7db21cd7f9d701c2221')
+
+prepare() {
+ cd "themis-$pkgver"
+ patch -p1 -i "$srcdir/makefile-ldconfig.patch"
+}
+
+build() {
+ cd "themis-$pkgver"
+ make
+}
+
+package() {
+ cd "themis-$pkgver"
+ make install PREFIX="$pkgdir/usr/"
+}
diff --git a/makefile-ldconfig.patch b/makefile-ldconfig.patch
new file mode 100644
index 000000000000..95934f221204
--- /dev/null
+++ b/makefile-ldconfig.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile b/Makefile
+index d4eaba55..c5aaefd5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -476,9 +476,6 @@ install: all install_soter install_themis
+ ifeq ($(IS_CENTOS),true)
+ -@mkdir -p "$$(dirname "$(LD_SO_CONF)")"
+ -@echo "$(libdir)" > "$(LD_SO_CONF)" && echo "Added $(libdir) to $(LD_SO_CONF)"
+-endif
+-ifdef IS_LINUX
+- -@ldconfig
+ endif
+ @if [ -e /usr/include/themis/themis.h ] && [ -e /usr/local/include/themis/themis.h ]; then \
+ echo ""; \