summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2024-03-20 21:26:31 -0500
committerLuis Martinez2024-03-20 21:26:31 -0500
commita4d7075769387ded75200893f58dcad22d1d98a8 (patch)
tree9268d1ee7024d97b611d45595247f3db01bc924c
parent0e8e70880a97401efee4bd063ab5227eaaf84b24 (diff)
downloadaur-a4d7075769387ded75200893f58dcad22d1d98a8.tar.gz
update to 0.15.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
2 files changed, 27 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddab191136aa..98556e6502e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = libthemis
pkgdesc = Open-source high-level cryptographic services library.
- pkgver = 0.13.12
+ pkgver = 0.15.2
pkgrel = 1
url = https://github.com/cossacklabs/themis
arch = x86_64
- license = Apache
- makedepends = make
- makedepends = gcc
+ license = Apache-2.0
depends = openssl
- source = https://github.com/cossacklabs/themis/archive/refs/tags/0.13.12.tar.gz
+ provides = libthemis.so
+ provides = libsoter.so
+ source = libthemis-0.15.2.tar.gz::https://github.com/cossacklabs/themis/archive/0.15.2.tar.gz
source = makefile-ldconfig.patch
- md5sums = 22e68c9a28f27f008fbadb3ea927abef
- md5sums = 5d5db18b2d72d7db21cd7f9d701c2221
+ sha256sums = ae1e7d7d20528c2ea627a863f9dc70a7e024069d80e563539bdefafecf5ec1fb
+ sha256sums = 5378f6535e5c2bd44d72d0f7b461307135578a656dd8f64c54367bc0a1e12a1f
pkgname = libthemis
diff --git a/PKGBUILD b/PKGBUILD
index cbb834f0478f..a97c171e146c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,37 @@
-# Maintainer: Mykyta Poturai <mykyta.poturai@tutanota.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Mykyta Poturai <mykyta.poturai@tutanota.com>
+
pkgname=libthemis
-pkgver=0.13.12
+pkgver=0.15.2
pkgrel=1
pkgdesc="Open-source high-level cryptographic services library."
url="https://github.com/cossacklabs/themis"
arch=('x86_64')
-license=('Apache')
+license=('Apache-2.0')
depends=('openssl')
-makedepends=('make' 'gcc')
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
+provides=('libthemis.so' 'libsoter.so')
changelog=
-source=("https://github.com/cossacklabs/themis/archive/refs/tags/$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
"makefile-ldconfig.patch")
-md5sums=('22e68c9a28f27f008fbadb3ea927abef'
- '5d5db18b2d72d7db21cd7f9d701c2221')
+sha256sums=('ae1e7d7d20528c2ea627a863f9dc70a7e024069d80e563539bdefafecf5ec1fb'
+ '5378f6535e5c2bd44d72d0f7b461307135578a656dd8f64c54367bc0a1e12a1f')
prepare() {
- cd "themis-$pkgver"
- patch -p1 -i "$srcdir/makefile-ldconfig.patch"
+ cd "themis-$pkgver"
+ patch -p1 -i "$srcdir/makefile-ldconfig.patch"
}
build() {
- cd "themis-$pkgver"
- make
+ cd "themis-$pkgver"
+ make
+}
+
+check() {
+ cd "themis-$pkgver"
+ make test
}
package() {
- cd "themis-$pkgver"
- make install PREFIX="$pkgdir/usr/"
+ cd "themis-$pkgver"
+ make install PREFIX="$pkgdir/usr/"
}