summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarms2015-07-06 21:38:34 +0200
committerHarms2015-07-06 21:38:34 +0200
commit3109e598ca6361dcc61ce160eb65a60ef7d8e721 (patch)
tree93eca0352896fba7bbab0263e496f6b3c18b68a1
downloadaur-3109e598ca6361dcc61ce160eb65a60ef7d8e721.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--libtheora-1.2.0alpha1.patch24
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66f610736096
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libtheora-ptalarbvorm
+ pkgdesc = An open video codec developed by the Xiph.org - ptalarbvorm version [unstable].
+ pkgver = 1.2.0alpha1
+ pkgrel = 2
+ url = http://www.theora.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = libvorbis
+ depends = libogg
+ provides = libtheora=${pkgver}
+ conflicts = libtheora
+ options = !libtool
+ source = http://downloads.xiph.org/releases/theora/libtheora-1.2.0alpha1.tar.xz
+ source = libtheora-1.2.0alpha1.patch
+ md5sums = 57de23dcd8bcf2ced4458924b01d2f51
+ md5sums = 68a29b838323b6eadd69b26337fbc55c
+
+pkgname = libtheora-ptalarbvorm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d67d842b72a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Harms <thotro@lyse.net>
+
+pkgname=libtheora-ptalarbvorm
+pkgver=1.2.0alpha1
+pkgrel=2
+pkgdesc="An open video codec developed by the Xiph.org - ptalarbvorm version [unstable]."
+arch=('i686' 'x86_64')
+depends=('libogg')
+makedepends=('libvorbis')
+provides=('libtheora=${pkgver}')
+conflicts=('libtheora')
+url="http://www.theora.org/"
+license=('custom')
+options=(!libtool)
+source=('http://downloads.xiph.org/releases/theora/libtheora-1.2.0alpha1.tar.xz' 'libtheora-1.2.0alpha1.patch')
+md5sums=('57de23dcd8bcf2ced4458924b01d2f51' '68a29b838323b6eadd69b26337fbc55c')
+
+build() {
+ cd "${srcdir}/libtheora-${pkgver}"
+ patch -Np1 -i "${srcdir}/libtheora-${pkgver}.patch"
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-shared --disable-static --disable-examples
+ make
+}
+package() {
+ cd "${srcdir}/libtheora-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ # Install the documents.
+ install -m755 -d "${pkgdir}/usr/share/licenses/libtheora"
+ install -m644 LICENSE COPYING "${pkgdir}/usr/share/licenses/libtheora/"
+}
diff --git a/libtheora-1.2.0alpha1.patch b/libtheora-1.2.0alpha1.patch
new file mode 100644
index 000000000000..a832ada03faa
--- /dev/null
+++ b/libtheora-1.2.0alpha1.patch
@@ -0,0 +1,24 @@
+diff -aur libtheora-1.2.0alpha1.pristine/configure.ac libtheora-1.2.0alpha1.new/configure.ac
+--- libtheora-1.2.0alpha1.pristine/configure.ac 2010-09-23 22:24:08.000000000 +0200
++++ libtheora-1.2.0alpha1.new/configure.ac 2014-04-09 22:15:16.849919034 +0200
+@@ -464,7 +464,7 @@
+ HAVE_PNG=no
+ if test "x$HAVE_PKG_CONFIG" = "xyes"
+ then
+- PKG_CHECK_MODULES(PNG, libpng, HAVE_PNG=yes, HAVE_PNG=no)
++ PKG_CHECK_MODULES(PNG, libpng12, HAVE_PNG=yes, HAVE_PNG=no)
+ fi
+ AC_SUBST(PNG_CFLAGS)
+ AC_SUBST(PNG_LIBS)
+diff -aur libtheora-1.2.0alpha1.pristine/examples/Makefile.am libtheora-1.2.0alpha1.new/examples/Makefile.am
+--- libtheora-1.2.0alpha1.pristine/examples/Makefile.am 2010-09-23 22:21:45.000000000 +0200
++++ libtheora-1.2.0alpha1.new/examples/Makefile.am 2014-04-09 22:15:29.279918830 +0200
+@@ -22,7 +22,7 @@
+
+ player_example_SOURCES = player_example.c
+ player_example_CFLAGS = $(SDL_CFLAGS) $(OGG_CFLAGS) $(VORBIS_CFLAGS)
+-player_example_LDADD = $(LDADDDEC) $(SDL_LIBS) $(VORBIS_LIBS) $(OSS_LIBS)
++player_example_LDADD = $(LDADDDEC) $(SDL_LIBS) $(VORBIS_LIBS) $(OSS_LIBS) -lm
+
+ encoder_example_SOURCES = encoder_example.c
+ EXTRA_encoder_example_SOURCES = getopt.c getopt1.c getopt.h