summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAstroFloyd2015-07-27 18:28:43 +0200
committerAstroFloyd2015-07-27 18:28:43 +0200
commita559b673657f8b6d71f5109d7a2cf352e13588ea (patch)
tree8a58d2ff425b0f37b341c2e124c947a919a3c559
downloadaur-a559b673657f8b6d71f5109d7a2cf352e13588ea.tar.gz
Initial commit: v0.3.2-2
-rw-r--r--.SRCINFO18
-rw-r--r--ChangeLog13
-rw-r--r--PKGBUILD25
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e53c4b107678
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libthesky
+ pkgdesc = Fortran library to compute the positions of celestial bodies and events with great accuracy
+ pkgver = 0.3.2
+ pkgrel = 2
+ url = http://libthesky.sourceforge.net/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = gcc-fortran
+ makedepends = libsufr
+ depends = gcc-libs
+ source = http://sourceforge.net/projects/libthesky/files/libthesky-0.3.2.tar.gz
+ sha512sums = 64fae18cf410c37d6bda5d65f8890a045734fa3bbaa23c76a8080ef06e15443af5159baf779b69594e24bb1fc8b0719ba03174764d46abed66f61750e8e9e68e
+
+pkgname = libthesky
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..468e1bddb719
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,13 @@
+
+ChangeLog for libTheSky PKGBUILD
+http://libthesky.sourceforge.net/
+
+* libthesky-0.3.2-2 (2015-04-28 - AstroFloyd)
+ Added cmake as a make dependency
+
+* libthesky-0.3.2-1 (2015-04-26 - AstroFloyd)
+ Version bump: 0.3.1 -> 0.3.2
+
+* libthesky-0.3.1-1 (2015-01-17 - AstroFloyd)
+ Initial PKGBUILD for libTheSky, to be uploaded to AUR
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31fb338c48a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: AstroFloyd < AstroFloyd [at] gmail [dt] com >
+pkgname=libthesky
+pkgver=0.3.2
+pkgrel=2
+pkgdesc="Fortran library to compute the positions of celestial bodies and events with great accuracy"
+arch=('i686' 'x86_64')
+url="http://libthesky.sourceforge.net/"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('cmake' 'gcc-fortran' 'libsufr')
+changelog=ChangeLog
+source=("http://sourceforge.net/projects/libthesky/files/$pkgname-$pkgver.tar.gz")
+sha512sums=('64fae18cf410c37d6bda5d65f8890a045734fa3bbaa23c76a8080ef06e15443af5159baf779b69594e24bb1fc8b0719ba03174764d46abed66f61750e8e9e68e')
+
+build() {
+ mkdir -p "$pkgname-$pkgver"/build
+ cd "$pkgname-$pkgver"/build/
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr/" ..
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"/build/
+ make install
+}