summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeopold Bloom2015-08-26 17:11:38 -0400
committerLeopold Bloom2015-08-26 17:11:38 -0400
commitf9857ce0edcdedc6f16565f2482c0d6f39b9ab2f (patch)
tree872d4659803178909e583430f32c91a4658ca534
downloadaur-f9857ce0edcdedc6f16565f2482c0d6f39b9ab2f.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--69-libticables.rules18
-rw-r--r--PKGBUILD32
-rw-r--r--libticables.install13
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e25182e0f979
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libticables
+ pkgdesc = TI Link Cable Library
+ pkgver = 1.3.4
+ pkgrel = 2
+ url = http://lpg.ticalc.org/prj_tilp/
+ install = libticables.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ options = !libtool
+ source = http://downloads.sourceforge.net/project/tilp/tilp2-linux/tilp2-1.17/libticables2-1.3.4.tar.bz2
+ source = 69-libticables.rules
+ sha256sums = 45cae91ad9ee1cc2ebc0f5865923ff77f1e0adf0793d3010eeb802efc140e5b0
+ sha256sums = e14a08b6a0c03f55c0f44de79de8896f0be5e8f7ccd5dd94f800c798f4fe79f8
+ sha512sums = fbea9ed2041a04f79e02045d40e88a3ab20edc8d86ecef4ae6a181063f3609b8b2c3aeb2ce2f4508be56655accba60eab7379116ac341921f233f469eb99b461
+ sha512sums = 423e0fcf072e7f4460ca00dedcc8839c3e22515f353813a058324dff0624c1eebcbd2385ca425fad351262520a30309d6d2a3148e4c0a5ec326eddb1428dbe1c
+
+pkgname = libticables
+
diff --git a/69-libticables.rules b/69-libticables.rules
new file mode 100644
index 000000000000..edf812c30ea8
--- /dev/null
+++ b/69-libticables.rules
@@ -0,0 +1,18 @@
+ACTION!="add", GOTO="libticables_end"
+
+# serial device (assume TI calculator)
+KERNEL=="ttyS[0-3]", ENV{ID_PDA}="1"
+# parallel device (assume TI calculator)
+SUBSYSTEM=="ppdev", ENV{ID_PDA}="1"
+# SilverLink
+SUBSYSTEM=="usb", ATTR{idVendor}=="0451", ATTR{idProduct}=="e001", ENV{ID_PDA}="1"
+# TI-84+ DirectLink
+SUBSYSTEM=="usb", ATTR{idVendor}=="0451", ATTR{idProduct}=="e003", ENV{ID_PDA}="1"
+# TI-89 Titanium DirectLink
+SUBSYSTEM=="usb", ATTR{idVendor}=="0451", ATTR{idProduct}=="e004", ENV{ID_PDA}="1"
+# TI-84+ SE DirectLink
+SUBSYSTEM=="usb", ATTR{idVendor}=="0451", ATTR{idProduct}=="e008", ENV{ID_PDA}="1"
+# TI-Nspire DirectLink
+SUBSYSTEM=="usb", ATTR{idVendor}=="0451", ATTR{idProduct}=="e012", ENV{ID_PDA}="1"
+
+LABEL="libticables_end"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee29cd0e2ed3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Taylor Lookabaugh <jesus.christ.i.love@gmail.com>
+# Contributor Jon Sturm <Jasturm002@aol.com>
+# Contributor: mickael9 <mickael9@gmail.com>
+
+pkgname=libticables
+pkgver=1.3.4
+pkgrel=2
+pkgdesc="TI Link Cable Library"
+arch=(i686 x86_64)
+url=http://lpg.ticalc.org/prj_tilp/
+license=(GPL2)
+options=(!libtool)
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/project/tilp/tilp2-linux/tilp2-1.17/${pkgname}2-$pkgver.tar.bz2
+ 69-$pkgname.rules)
+sha256sums=('45cae91ad9ee1cc2ebc0f5865923ff77f1e0adf0793d3010eeb802efc140e5b0'
+ 'e14a08b6a0c03f55c0f44de79de8896f0be5e8f7ccd5dd94f800c798f4fe79f8')
+sha512sums=('fbea9ed2041a04f79e02045d40e88a3ab20edc8d86ecef4ae6a181063f3609b8b2c3aeb2ce2f4508be56655accba60eab7379116ac341921f233f469eb99b461'
+ '423e0fcf072e7f4460ca00dedcc8839c3e22515f353813a058324dff0624c1eebcbd2385ca425fad351262520a30309d6d2a3148e4c0a5ec326eddb1428dbe1c')
+
+build() {
+ cd ${pkgname}2-$pkgver/
+ autoreconf -fi
+ ./configure --prefix=/usr --enable-libusb10
+ make
+}
+
+package() {
+ make -C ${pkgname}2-$pkgver DESTDIR="$pkgdir" install
+ install -Dm644 69-$pkgname.rules "$pkgdir"/etc/udev/rules.d/69-$pkgname.rules
+}
diff --git a/libticables.install b/libticables.install
new file mode 100644
index 000000000000..eab1787b043d
--- /dev/null
+++ b/libticables.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo -n "Reloading udev rules..."
+ udevadm control --reload-rules
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}