summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-12-28 01:12:51 +0800
committerChocobo12017-12-28 01:22:36 +0800
commitdfc129db2ace548c6f3ffc36b62b54bd243e8bb6 (patch)
tree8ee313c180f09c6ba27992478121a44459570554
downloadaur-dfc129db2ace548c6f3ffc36b62b54bd243e8bb6.tar.gz
newpkg: libtiff-git 4.0.9.r32.g5848777b-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69f1e032da3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libtiff-git
+ pkgdesc = TIFF library and utilities
+ pkgver = 4.0.9.r32.g5848777b
+ pkgrel = 1
+ url = http://www.simplesystems.org/libtiff/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = glibc
+ depends = libjpeg
+ depends = xz
+ depends = zlib
+ provides = libtiff
+ conflicts = libtiff
+ options = staticlibs
+ source = git+https://gitlab.com/libtiff/libtiff.git
+ sha256sums = SKIP
+
+pkgname = libtiff-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9caf89b000b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libtiff-git
+pkgver=4.0.9.r32.g5848777b
+pkgrel=1
+pkgdesc="TIFF library and utilities"
+arch=('i686' 'x86_64')
+url="http://www.simplesystems.org/libtiff/"
+license=('custom')
+depends=('glibc' 'libjpeg' 'xz' 'zlib')
+makedepends=('git')
+provides=('libtiff')
+conflicts=('libtiff')
+options=('staticlibs')
+source=("git+https://gitlab.com/libtiff/libtiff.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libtiff"
+
+ git describe --long --tags | sed 's/^Release-v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libtiff"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libtiff"
+
+ make check
+}
+
+package() {
+ cd "libtiff"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYRIGHT" "$pkgdir/usr/share/licenses/libtiff/COPYRIGHT"
+}