summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-08-23 14:04:47 +0200
committersmls2015-08-23 14:04:47 +0200
commit03965b69bf5b6c2766501019f15ffb47e3d24c08 (patch)
tree45a99ad7e60193849036aeb79c72e2c543ef295c
parent1b14183f6fc1ce5af9ecec5ec8ecfbbf81693b74 (diff)
downloadaur-03965b69bf5b6c2766501019f15ffb47e3d24c08.tar.gz
turn it into a split package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b3e72636a5..0a05702c91a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,6 @@
pkgbase = libtiff3
- pkgdesc = Library for manipulation of TIFF images (legacy version)
pkgver = 3.9.7
- pkgrel = 2
+ pkgrel = 4
url = http://www.remotesensing.org/libtiff/
arch = i686
arch = x86_64
@@ -11,10 +10,16 @@ pkgbase = libtiff3
depends = zlib
depends = libtiff
optdepends = freeglut: for using tiffgt
- provides = libtiff3
- provides = libtiff4
source = http://download.osgeo.org/libtiff/tiff-3.9.7.tar.gz
sha256sums = f5d64dd4ce61c55f5e9f6dc3920fbe5a41e02c2e607da7117a35eb5c320cef6a
pkgname = libtiff3
+ pkgdesc = Library for manipulation of TIFF images (legacy version, provides libtiff.so.3)
+
+pkgname = libtiff4
+ pkgdesc = Library for manipulation of TIFF images (legacy version, provides libtiff.so.4)
+ depends = libjpeg
+ depends = zlib
+ depends = libtiff
+ depends = libtiff3
diff --git a/PKGBUILD b/PKGBUILD
index c942e28ed23f..a6ac839a08a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,9 @@
# Contributor: Eric BĂ©langer <eric@archlinux.org>
# Contributor: Joost Bremmer <toost dot b at gmail dot com>
-pkgname=libtiff3
+pkgname=(libtiff3 libtiff4)
pkgver=3.9.7
-pkgrel=2
-pkgdesc="Library for manipulation of TIFF images (legacy version)"
+pkgrel=4
arch=('i686' 'x86_64')
url="http://www.remotesensing.org/libtiff/"
license=('custom')
@@ -16,7 +15,6 @@ makedepends=('freeglut')
optdepends=('freeglut: for using tiffgt')
source=("http://download.osgeo.org/libtiff/tiff-$pkgver.tar.gz")
sha256sums=('f5d64dd4ce61c55f5e9f6dc3920fbe5a41e02c2e607da7117a35eb5c320cef6a')
-provides=('libtiff3' 'libtiff4')
build() {
cd tiff-$pkgver
@@ -29,7 +27,9 @@ check() {
make check
}
-package() {
+package_libtiff3() {
+ pkgdesc="Library for manipulation of TIFF images (legacy version, provides libtiff.so.3)"
+
cd tiff-$pkgver
make DESTDIR="$pkgdir" install
install -D -m644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
@@ -40,8 +40,14 @@ package() {
rm -rf "$pkgdir"/usr/include
rm -rf "$pkgdir"/usr/share/man
rm -rf "$pkgdir"/usr/share/doc
+}
+
+package_libtiff4() {
+ pkgdesc="Library for manipulation of TIFF images (legacy version, provides libtiff.so.4)"
+ depends+=('libtiff3')
# see http://www.asmail.be/msg0055009514.html
+ install -d "$pkgdir"/usr/lib
ln -sf libtiff.so.$pkgver "$pkgdir"/usr/lib/libtiff.so.4
ln -sf libtiffxx.so.$pkgver "$pkgdir"/usr/lib/libtiffxx.so.4
}