summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-10 01:36:55 +0200
committersmls2015-07-10 01:36:55 +0200
commit818e195cd9a3443ca9d5b64fb0b0763433a8b2e7 (patch)
treedd748c7026efd33703147144c83738510062ad7d
downloadaur-818e195cd9a3443ca9d5b64fb0b0763433a8b2e7.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98ff4367e029
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libtiff3
+ pkgdesc = Library for manipulation of TIFF images, legacy version, links to libtiff.so.3
+ pkgver = 3.9.7
+ pkgrel = 1
+ url = http://www.remotesensing.org/libtiff/
+ arch = any
+ license = custom
+ depends = libtiff4
+ optdepends = freeglut: for using tiffgt
+ options = !libtool
+
+pkgname = libtiff3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fe94c986376
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Miguel Revilla <yo@miguelrevilla.com>
+# Contributor: josephgbr <rafael.f.f1@gmail.com>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=libtiff3
+pkgver=3.9.7
+pkgrel=1
+pkgdesc="Library for manipulation of TIFF images, legacy version, links to libtiff.so.3"
+arch=('any')
+url="http://www.remotesensing.org/libtiff/"
+license=('custom')
+depends=('libtiff4')
+optdepends=('freeglut: for using tiffgt')
+options=('!libtool')
+
+package() {
+ cd "${pkgdir}"
+ mkdir usr
+ mkdir usr/lib
+ cd usr/lib
+ ln -s libtiff.so.${pkgver} libtiff.so.3
+ ln -s libtiffxx.so.${pkgver} libtiffxx.so.3
+ cd ..
+ mkdir share
+ mkdir share/licenses
+ cd share/licenses
+ ln -s libtiff4 libtiff3
+}