summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-22 22:30:53 -0500
committerVincent Grande2021-01-22 22:30:53 -0500
commit58f3d09c5e9389ea7884cdf90006e1a2aab211a5 (patch)
tree9fbd75127b77ad4455c7e3ca64d324f82210db58
downloadaur-58f3d09c5e9389ea7884cdf90006e1a2aab211a5.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD57
-rw-r--r--libtiff4-soname.patch15
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6db3857d47ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libtiff4-git
+ pkgdesc = Library for manipulation of TIFF images
+ pkgver = 3.9.7
+ pkgrel = 1
+ url = http://www.simplesystems.org/libtiff/
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = gcc-libs
+ depends = libjpeg-turbo
+ depends = zlib
+ provides = libtiff4
+ conflicts = libtiff4
+ source = git+https://gitlab.com/libtiff/libtiff.git#branch-3.9
+ source = libtiff4-soname.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = libtiff4-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c815244f419
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Vincent Grande <shoobe420@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: lorim <lorimz@gmail.com>
+
+pkgname=libtiff4-git
+pkgver=3.9.7
+pkgrel=1
+pkgdesc='Library for manipulation of TIFF images'
+arch=(x86_64)
+url=http://www.simplesystems.org/libtiff/
+license=(custom)
+depends=(
+ gcc-libs
+ libjpeg-turbo
+ zlib
+)
+makedepends=(git)
+provides=(libtiff4)
+conflicts=(libtiff4)
+source=(
+ git+https://gitlab.com/libtiff/libtiff.git#branch-3.9
+ libtiff4-soname.patch
+)
+sha256sums=(
+ SKIP
+ SKIP
+)
+
+pkgver() {
+ cd libtiff
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd libtiff
+
+ # Rename 3.9.7 to 4.3.7, 3.6.x was the first release with the unintentional ABI change
+ patch -Np1 -i ../libtiff4-soname.patch
+
+ ./autogen.sh
+}
+
+build() {
+ cd libtiff
+
+ ./configure \
+ --prefix='/usr'
+ make
+}
+
+package() {
+ make DESTDIR="${pkgdir}" -C libtiff install
+ rm -rf "${pkgdir}"/usr/{bin,include,lib/libtiff{,xx}.{a,so},share}
+ install -Dm 644 libtiff/COPYRIGHT -t "${pkgdir}"/usr/share/licenses/libtiff4/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/libtiff4-soname.patch b/libtiff4-soname.patch
new file mode 100644
index 000000000000..61c5ff2f292f
--- /dev/null
+++ b/libtiff4-soname.patch
@@ -0,0 +1,15 @@
+diff --git a/configure.ac b/configure.ac
+index e7cf8041..fb869708 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -39,8 +39,8 @@ AM_MAINTAINER_MODE
+
+ dnl Versioning.
+ dnl Don't fill the ALPHA_VERSION field, if not applicable.
+-LIBTIFF_MAJOR_VERSION=3
+-LIBTIFF_MINOR_VERSION=9
++LIBTIFF_MAJOR_VERSION=4
++LIBTIFF_MINOR_VERSION=3
+ LIBTIFF_MICRO_VERSION=7
+ LIBTIFF_ALPHA_VERSION=
+ LIBTIFF_VERSION=$LIBTIFF_MAJOR_VERSION.$LIBTIFF_MINOR_VERSION.$LIBTIFF_MICRO_VERSION$LIBTIFF_ALPHA_VERSION