summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2017-01-18 17:57:19 -0700
committeramagura2017-01-18 17:57:19 -0700
commit1c14e243089be8a6b0c0f3d4ac6a5870914fb59a (patch)
treeca62e5cc22c89ce1616460ca4d9ea60dd0d94fa4
parent41f0bf4f34c6d8277c77e9d8c9a9e30b301a4b5b (diff)
downloadaur-1c14e243089be8a6b0c0f3d4ac6a5870914fb59a.tar.gz
adds support for libtinfo5 _if_ ncurses5-compat-libs is installed _before_ installing libtinfo
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c3d1971757e..260af117fd47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Sat Dec 24 00:20:45 UTC 2016
+# Thu Jan 19 00:56:28 UTC 2017
pkgbase = libtinfo
pkgdesc = symlink to ncurses for use in cuda and other packages
pkgver = 6
- pkgrel = 16
+ pkgrel = 17
url = http://www.gnu.org/software/ncurses/
arch = any
license = MIT
depends = ncurses>=6.0
+ optdepends = libtinfo5: ncurses5-compat-libs
pkgname = libtinfo
diff --git a/PKGBUILD b/PKGBUILD
index e5733859c895..8ef5e6c0b43c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,25 @@
#
pkgname=libtinfo
pkgver=6
-pkgrel=16
+pkgrel=17
pkgdesc="symlink to ncurses for use in cuda and other packages"
arch=('any')
url="http://www.gnu.org/software/ncurses/"
license=('MIT')
#conflicts=('libtinfo-5')
depends=('ncurses>=6.0')
+optdepends=('libtinfo5: ncurses5-compat-libs')
_ncurses="$(pacman -Q ncurses | awk '{print $2}' | cut -c 1-3)"
+_libtinfo5="$(pacman -Q ncurses5-compat-libs > /dev/null 2>&1; echo $?)"
package() {
install -d "$pkgdir"/usr/lib
ln -s /usr/lib/libncursesw.so."$_ncurses" "$pkgdir"/usr/lib/libtinfo.so."$pkgver"
ln -s /usr/lib/libtinfo.so."$pkgver" "$pkgdir"/usr/lib/libtinfo.so
-# ln -s /usr/lib/libtinfo.so."$pkgver" "$pkgdir"/usr/lib/libtinfo.so.5
+
+ if ((_libtinfo5)); then
+ ln -s /usr/lib/libncurses.so.5 "$pkgdir"/usrlib/libtinfo.so.5
+ fi
}
#package_lib32_libtinfo() {