summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2015-06-08 23:22:12 -0600
committeramagura2015-06-08 23:22:12 -0600
commit53d3be67963ca680308a2706df10f82c5e7801b4 (patch)
treecd06cd7612f59075cd6d78fb063811f862d07a91
downloadaur-53d3be67963ca680308a2706df10f82c5e7801b4.tar.gz
initial import
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3693219fa285
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = libtinfo
+ pkgdesc = symlink to ncurses for use in cuda and other packages
+ pkgver = 5
+ pkgrel = 6
+ url = http://www.gnu.org/software/ncurses/
+ arch = any
+ license = unknown
+ depends = ncurses
+
+pkgname = libtinfo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1112d11e12bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Alexej Magura <agm2819*gmail*>
+#
+#
+pkgname=libtinfo
+pkgver=5
+pkgrel=6
+pkgdesc="symlink to ncurses for use in cuda and other packages"
+arch=('any')
+url="http://www.gnu.org/software/ncurses/"
+license=('unknown')
+depends=('ncurses')
+#source=("")
+#md5sums=('')
+_ncurses="$(pacman -Q $depends | awk '{sub(/-[0-9]+/, "", $2); print $2}')"
+
+package() {
+ install -d "$pkgdir"/usr/lib
+ ln -s /usr/lib/libncurses.so."$_ncurses" -T "$pkgdir"/usr/lib/libtinfo.so."$pkgver"
+ ln -s /usr/lib/libtinfo.so."$pkgver" -T "$pkgdir"/usr/lib/libtinfo.so
+}