summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2017-04-29 12:33:44 -0600
committeramagura2017-04-29 12:33:44 -0600
commit9c95d70161742a71d3b91c10bf7c2517129af43a (patch)
tree80b307bd42bdc51998a89869dd5bd98ddcb30dc1
parent5906b2b251d57aed469331d4e81e7bb148e6c1cd (diff)
downloadaur-9c95d70161742a71d3b91c10bf7c2517129af43a.tar.gz
rolling back to a working version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD36
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3c5031938dc..3df08b9bdca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Sat Apr 29 18:03:09 UTC 2017
+# Sat Apr 29 18:33:35 UTC 2017
pkgbase = libtinfo
pkgdesc = symlink to ncurses for use in cuda and other packages
pkgver = 6
- pkgrel = 22
+ pkgrel = 20
url = http://www.gnu.org/software/ncurses/
arch = any
license = MIT
depends = ncurses>=6.0
- depends = ncurses5-compat-libs
+ optdepends = libtinfo5: ncurses5-compat-libs
pkgname = libtinfo
diff --git a/PKGBUILD b/PKGBUILD
index 37b6e30ad6bb..ea61ca1d5f7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,36 @@
#
pkgname=libtinfo
pkgver=6
-pkgrel=22
+pkgrel=20
pkgdesc="symlink to ncurses for use in cuda and other packages"
arch=('any')
url="http://www.gnu.org/software/ncurses/"
license=('MIT')
#conflicts=('libtinfo-5')
-depends=('ncurses>=6.0' 'ncurses5-compat-libs')
-#optdepends=('libtinfo5: ncurses5-compat-libs')
-#_ncurses="$(pacman -Q ncurses | awk '{print $2}' | cut -c 1-3)"
-#_libtinfo5="$(pacman -Q ncurses5-compat-libs > /dev/null 2>&1; echo $?)"
+depends=('ncurses>=6.0')
+optdepends=('libtinfo5: ncurses5-compat-libs')
+_ncurses="$(pacman -Q ncurses | awk '{print $2}' | cut -c 1-3)"
+_libtinfo5="$(pacman -Q ncurses5-compat-libs > /dev/null 2>&1; echo $?)"
package() {
install -d "$pkgdir"/usr/lib
ln -s /usr/lib/libncursesw.so."$_ncurses" "$pkgdir"/usr/lib/libtinfo.so."$pkgver"
ln -s /usr/lib/libtinfo.so."$pkgver" "$pkgdir"/usr/lib/libtinfo.so
- #msg "Is ncurses5-compat-libs present..."
+ msg "Is ncurses5-compat-libs present..."
- #if ! ((_libtinfo5)); then
- #msg "\tyes"
- #msg "Do we need to symlink to it..."
- #if [[ -f /usr/lib/libtinfo.so.5 ]]; then
- #msg "\tno"
- #else
- #msg "\tyes"
- #ln -s /usr/lib/libncurses.so.5 "$pkgdir"/usr/lib/libtinfo.so.5
- #fi
- #else
- #msg "\tno"
- #fi
+ if ! ((_libtinfo5)); then
+ msg "\tyes"
+ msg "Do we need to symlink to it..."
+ if [[ -f /usr/lib/libtinfo.so.5 ]]; then
+ msg "\tno"
+ else
+ msg "\tyes"
+ ln -s /usr/lib/libncurses.so.5 "$pkgdir"/usr/lib/libtinfo.so.5
+ fi
+ else
+ msg "\tno"
+ fi
}
#package_lib32_libtinfo() {