summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2017-07-28 15:41:54 -0600
committeramagura2017-07-28 15:41:54 -0600
commit9fefcc6472cad8476620e6d47185db1e6e35e326 (patch)
tree54ad271e2439c17c1b228bcf650144ab562387d8
parent987c98c1fc1d2a385ee2fb7061406b1cfff932e4 (diff)
downloadaur-9fefcc6472cad8476620e6d47185db1e6e35e326.tar.gz
no longer provides libtinfo5 as requested
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD32
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 795bf208bd2f..94559ebddeaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
# Generated by mksrcinfo v8
-# Sat Apr 29 18:34:27 UTC 2017
+# Fri Jul 28 21:41:53 UTC 2017
pkgbase = libtinfo
pkgdesc = symlink to ncurses for use in cuda and other packages
pkgver = 6
- pkgrel = 23
+ pkgrel = 24
url = http://www.gnu.org/software/ncurses/
arch = any
license = MIT
depends = ncurses>=6.0
- optdepends = libtinfo5: ncurses5-compat-libs
pkgname = libtinfo
diff --git a/PKGBUILD b/PKGBUILD
index a05327c7ac09..4459ae09a698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,36 @@
#
pkgname=libtinfo
pkgver=6
-pkgrel=23
+pkgrel=24
pkgdesc="symlink to ncurses for use in cuda and other packages"
arch=('any')
url="http://www.gnu.org/software/ncurses/"
license=('MIT')
#conflicts=('libtinfo-5')
depends=('ncurses>=6.0')
-optdepends=('libtinfo5: ncurses5-compat-libs')
+#optdepends=('libtinfo5: ncurses5-compat-libs')
_ncurses="$(pacman -Q ncurses | awk '{print $2}' | cut -c 1-3)"
-_libtinfo5="$(pacman -Q ncurses5-compat-libs > /dev/null 2>&1; echo $?)"
+#_libtinfo5="$(pacman -Q ncurses5-compat-libs > /dev/null 2>&1; echo $?)"
package() {
install -d "$pkgdir"/usr/lib
ln -s /usr/lib/libncursesw.so."$_ncurses" "$pkgdir"/usr/lib/libtinfo.so."$pkgver"
ln -s /usr/lib/libtinfo.so."$pkgver" "$pkgdir"/usr/lib/libtinfo.so
- msg "Is ncurses5-compat-libs present..."
+ #msg "Is ncurses5-compat-libs present..."
- if ! ((_libtinfo5)); then
- msg "\tyes"
- msg "Do we need to symlink to it..."
- if [[ -f /usr/lib/libtinfo.so.5 ]]; then
- msg "\tno"
- else
- msg "\tyes"
- ln -s /usr/lib/libncurses.so.5 "$pkgdir"/usr/lib/libtinfo.so.5
- fi
- else
- msg "\tno"
- fi
+ #if ! ((_libtinfo5)); then
+ #msg "\tyes"
+ #msg "Do we need to symlink to it..."
+ #if [[ -f /usr/lib/libtinfo.so.5 ]]; then
+ #msg "\tno"
+ #else
+ #msg "\tyes"
+ #ln -s /usr/lib/libncurses.so.5 "$pkgdir"/usr/lib/libtinfo.so.5
+ #fi
+ #else
+ #msg "\tno"
+ #fi
}
#package_lib32_libtinfo() {