summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2017-02-16 09:08:29 +0200
committerAndrey Vihrov2017-02-16 09:08:29 +0200
commitd2d089122722d3bb27887e48d3ddb57617eda25a (patch)
tree372e78d318e86d64095324348ae92b6aee0d257a
parentb18a0f335b7276c76d19ec22e39002a631c1d398 (diff)
downloadaur-d2d089122722d3bb27887e48d3ddb57617eda25a.tar.gz
Make sure "make install" receives the same environment as in build()
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56f152484f6d..10cbe9c02120 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,15 +27,15 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
- CPPFLAGS+=" -DLTM_DESC -DGMP_DESC" \
- EXTRALIBS="${LDFLAGS} -ltommath -lgmp" \
+ export CPPFLAGS+=" -DLTM_DESC -DGMP_DESC"
+ export EXTRALIBS="${LDFLAGS} -ltommath -lgmp"
make -f makefile.shared IGNORE_SPEED=1
}
check() {
cd "${pkgname}-${pkgver}"
- CPPFLAGS+=" -DLTM_DESC -DUSE_LTM -I./testprof" \
+ CPPFLAGS+=" -DUSE_LTM -I./testprof" \
EXTRALIBS="${LDFLAGS} -L./.libs -L./testprof/.libs" \
make -f makefile.shared test IGNORE_SPEED=1
LD_LIBRARY_PATH="./.libs:./testprof/.libs" ./test
@@ -44,7 +44,7 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
- make -f makefile.shared DESTDIR="${pkgdir}" INSTALL_GROUP="root" install
+ make -f makefile.shared DESTDIR="${pkgdir}" INSTALL_GROUP="root" IGNORE_SPEED=1 install
install -D -m 0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}