summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2017-10-11 21:40:36 +0300
committerAndrey Vihrov2017-10-11 21:40:36 +0300
commitd4999023f8c437145d90ad893480ee5dcacdd6ba (patch)
tree1535f17a841166ff16bb00ff0115806423b8bd07
parent6ad28e88775b0781f2efb271b97555a371900e00 (diff)
downloadaur-d4999023f8c437145d90ad893480ee5dcacdd6ba.tar.gz
Update to 1.18.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2934049aea2a..6057caf10b49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Oct 2 16:05:18 UTC 2017
+# Wed Oct 11 18:39:53 UTC 2017
pkgbase = libtomcrypt
pkgdesc = A fairly comprehensive, modular and portable cryptographic toolkit
- pkgver = 1.18.0rc5
+ pkgver = 1.18.0
pkgrel = 1
url = http://www.libtom.net/LibTomCrypt/
arch = i686
@@ -10,9 +10,9 @@ pkgbase = libtomcrypt
license = custom:PublicDomain
depends = libtommath
depends = gmp
- source = https://github.com/libtom/libtomcrypt/releases/download/v1.18.0-rc5/crypt-1.18.0-rc5.tar.xz
- source = https://github.com/libtom/libtomcrypt/releases/download/v1.18.0-rc5/crypt-1.18.0-rc5.tar.xz.asc
- sha256sums = 55af6a820e7be83efb99a39a98eb005c188655078e4c1683b4099d89e415ec55
+ source = https://github.com/libtom/libtomcrypt/releases/download/v1.18.0/crypt-1.18.0.tar.xz
+ source = https://github.com/libtom/libtomcrypt/releases/download/v1.18.0/crypt-1.18.0.tar.xz.asc
+ sha256sums = da9df56a314afaab71963aa71bb6a075ea6bdee3d4db4af045f6bfe23e88b87a
sha256sums = SKIP
pkgname = libtomcrypt
diff --git a/PKGBUILD b/PKGBUILD
index 28bbf65d31a5..4d6bafe09746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,20 @@
# Contributor: Michael Fellinger <m.fellinger@gmail.com>
pkgname=libtomcrypt
-pkgver=1.18.0rc5
-_pkgver="${pkgver/rc/-rc}"
+pkgver=1.18.0
pkgrel=1
pkgdesc="A fairly comprehensive, modular and portable cryptographic toolkit"
arch=('i686' 'x86_64')
url="http://www.libtom.net/LibTomCrypt/"
license=('custom:PublicDomain')
depends=('libtommath' 'gmp')
-source=("https://github.com/libtom/${pkgname}/releases/download/v${_pkgver}/${pkgname#libtom}-${_pkgver}.tar.xz"{,.asc})
-sha256sums=('55af6a820e7be83efb99a39a98eb005c188655078e4c1683b4099d89e415ec55'
+source=("https://github.com/libtom/${pkgname}/releases/download/v${pkgver}/${pkgname#libtom}-${pkgver}.tar.xz"{,.asc})
+sha256sums=('da9df56a314afaab71963aa71bb6a075ea6bdee3d4db4af045f6bfe23e88b87a'
'SKIP')
validpgpkeys=('C4386A237ED43A475541B9427B2CD0DD4BCFF59B') # Steffen Jaeckel <s_jaeckel@gmx.de>
build() {
- cd "${pkgname}-${_pkgver}"
+ cd "${pkgname}-${pkgver}"
export CPPFLAGS+=" -DLTM_DESC -DGMP_DESC -DUSE_LTM"
export EXTRALIBS="-ltommath -lgmp"
@@ -25,12 +24,12 @@ build() {
}
check() {
- cd "${pkgname}-${_pkgver}"
+ cd "${pkgname}-${pkgver}"
./test
}
package() {
- cd "${pkgname}-${_pkgver}"
+ cd "${pkgname}-${pkgver}"
make -f makefile.shared DESTDIR="${pkgdir}" PREFIX="/usr" INSTALL_GROUP="root" INSTALL_OPTS="" install