summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2022-03-23 18:52:48 +0800
committerAllen Zhong2022-03-23 18:52:48 +0800
commit862ae1c8c2c8de7dc5b0984387ded732156f9206 (patch)
tree0773d4aca2a965a3392c1bd343e4547ebaea15ac
parent4f2d95e9790dc316d16cfc477bc441984af278fd (diff)
downloadaur-862ae1c8c2c8de7dc5b0984387ded732156f9206.tar.gz
update source to latest dev branch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 251b1eb59780..cb934815b7a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libtorrent-ipv6
pkgdesc = BitTorrent library with a focus on high performance and good code, with ipv6 support
pkgver = 0.13.8
- pkgrel = 1
+ pkgrel = 3
url = http://rakshasa.github.io/rtorrent/
arch = x86_64
license = GPL
@@ -10,8 +10,7 @@ pkgbase = libtorrent-ipv6
depends = zlib
provides = libtorrent
conflicts = libtorrent
- source = libtorrent::git+https://github.com/rakshasa/libtorrent.git#commit=bd3e232a2fdb91a2eb93994bb18e5e0e3d2f6235
+ source = libtorrent::git+https://github.com/rakshasa/libtorrent.git#commit=ac8d6d1be5341e8dfa4ac33fef0bf8940a00c8f3
sha256sums = SKIP
pkgname = libtorrent-ipv6
-
diff --git a/PKGBUILD b/PKGBUILD
index e060eeaa814c..b4a1fff38afa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=libtorrent
pkgname=libtorrent-ipv6
pkgver=0.13.8
-pkgrel=1
+pkgrel=3
pkgdesc='BitTorrent library with a focus on high performance and good code, with ipv6 support'
url='http://rakshasa.github.io/rtorrent/'
arch=('x86_64')
@@ -18,19 +18,22 @@ depends=('openssl' 'zlib')
makedepends=('git')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-source=("$_pkgname::git+https://github.com/rakshasa/libtorrent.git#commit=bd3e232a2fdb91a2eb93994bb18e5e0e3d2f6235")
+source=("$_pkgname::git+https://github.com/rakshasa/libtorrent.git#commit=ac8d6d1be5341e8dfa4ac33fef0bf8940a00c8f3")
sha256sums=('SKIP')
prepare() {
cd "${srcdir}/${_pkgname}"
sed '/AM_PATH_CPPUNIT/d' -i configure.ac
+ aclocal -I ./scripts -I .
+ autoheader
+ libtoolize --automake --copy --force
+ automake --add-missing --copy --gnu
+ autoconf
}
build() {
cd "${srcdir}/${_pkgname}"
- ./autogen.sh
-
- export CXXFLAGS="${CXXFLAGS} -std=c++11 -fno-strict-aliasing"
+ export CXXFLAGS="${CXXFLAGS} -std=c++14 -fno-strict-aliasing"
./configure \
--prefix=/usr \
--disable-debug