summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2017-05-20 16:01:29 +0000
committerxsmile2017-05-20 16:01:29 +0000
commit714cebf353a9260f2009ed0bd7e1fe4a28c82818 (patch)
treef3f5bdc2c5e948b86e6742a1120fc93f450eb58e
parent7ab893d01e3ab5257c12d55c5f6528e92b685f95 (diff)
downloadaur-714cebf353a9260f2009ed0bd7e1fe4a28c82818.tar.gz
skip cppunit dependency check
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
-rw-r--r--lt-open-ssl-1.1.patch (renamed from openssl-1.1.patch)12
-rw-r--r--skip-cppunit.patch10
5 files changed, 28 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5c6d9572590..42e647a907ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
# Generated by mksrcinfo v8
-# Fri May 12 02:02:30 UTC 2017
+# Sat May 20 15:59:31 UTC 2017
pkgbase = libtorrent-ps
pkgdesc = BitTorrent library written in C++ for use with rtorrent-ps
- pkgver = 1.0.r57.gb49dfe3
+ pkgver = 1.0.r59.gd21c734
pkgrel = 1
url = https://github.com/rakshasa/libtorrent
arch = any
license = GPL
- makedepends = cppunit
depends = openssl
provides = libtorrent
conflicts = libtorrent
source = https://github.com/rakshasa/libtorrent/archive/0.13.6.tar.gz
source = lt-ps-honor_system_file_allocate_all.patch
source = lt-ps-log_open_file-reopen_all.patch
- source = openssl-1.1.patch
+ source = lt-open-ssl-1.1.patch
+ source = skip-cppunit.patch
md5sums = 8c8eaa9fa03bd113967c68eea26493e7
md5sums = 8d7f8fe5ad412bd42f2ea66131a8ce6b
md5sums = 2bfadac7770935ca98c4714c2011541a
- md5sums = 08a51eb090e49fa24a9792d39333a5ac
+ md5sums = 1fc8eca467b3e5a5b5c43bbef21f4ba8
+ md5sums = e142e5513fe0782b16cab1099edcec66
pkgname = libtorrent-ps
diff --git a/.gitignore b/.gitignore
index dc1560e8973b..8766688f9756 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
-# (release) archives
+# common
+src/
+pkg/
*.tar*
diff --git a/PKGBUILD b/PKGBUILD
index ebb81ead0b24..16d8524c9ec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,37 @@
_pkgname=libtorrent
pkgname=libtorrent-ps
_pkgver=0.13.6
-pkgver=1.0.r57.gb49dfe3
+pkgver=1.0.r59.gd21c734
pkgrel=1
pkgdesc='BitTorrent library written in C++ for use with rtorrent-ps'
url='https://github.com/rakshasa/libtorrent'
license=('GPL')
arch=('any')
depends=('openssl')
-makedepends=('cppunit')
provides=('libtorrent')
conflicts=('libtorrent')
source=("https://github.com/rakshasa/$_pkgname/archive/$_pkgver.tar.gz"
'lt-ps-honor_system_file_allocate_all.patch'
'lt-ps-log_open_file-reopen_all.patch'
- 'openssl-1.1.patch')
+ 'lt-open-ssl-1.1.patch'
+ 'skip-cppunit.patch')
md5sums=('8c8eaa9fa03bd113967c68eea26493e7'
'8d7f8fe5ad412bd42f2ea66131a8ce6b'
'2bfadac7770935ca98c4714c2011541a'
- '08a51eb090e49fa24a9792d39333a5ac')
+ '1fc8eca467b3e5a5b5c43bbef21f4ba8'
+ 'e142e5513fe0782b16cab1099edcec66')
prepare() {
cd "$srcdir/$_pkgname-$_pkgver"
+ LT_PATCHES=( "$srcdir"/lt-open-ssl-1.1.patch
+ "$srcdir"/skip-cppunit.patch )
+
# Patch libtorrent
- for corepatch in $srcdir/lt-ps-*_{${_pkgver},all}.patch; do
+ for corepatch in "$srcdir"/lt-ps-*_{"${_pkgver}",all}.patch "${LT_PATCHES[@]}"; do
test ! -e "$corepatch" || { msg2 "$(basename $corepatch)"; patch -uNp1 -i "$corepatch"; }
done
- # Fix build against OpenSSL 1.1
- patch -p1 -i ../openssl-1.1.patch
-
./autogen.sh
}
diff --git a/openssl-1.1.patch b/lt-open-ssl-1.1.patch
index 47e23c5df7f3..665296f7e2e3 100644
--- a/openssl-1.1.patch
+++ b/lt-open-ssl-1.1.patch
@@ -1,15 +1,3 @@
-From 4607bbf78040789dee29266878ce109136b984ef Mon Sep 17 00:00:00 2001
-From: rakshasa <sundell.software@gmail.com>
-Date: Tue, 20 Dec 2016 19:51:02 +0900
-Subject: [PATCH] Added support for openssl 1.1.
-
----
- configure.ac | 4 ++++
- src/utils/diffie_hellman.cc | 36 ++++++++++++++++++++++++++++++++++--
- 2 files changed, 38 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 65e3487..27e3357 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,12 +69,15 @@ AC_ARG_ENABLE(openssl,
diff --git a/skip-cppunit.patch b/skip-cppunit.patch
new file mode 100644
index 000000000000..417199a602e8
--- /dev/null
+++ b/skip-cppunit.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac 2017-05-20 15:41:43.053441103 +0000
++++ b/configure.ac 2017-05-20 15:42:02.103400529 +0000
+@@ -19,7 +19,6 @@
+
+ AM_INIT_AUTOMAKE
+ AC_CONFIG_HEADERS(config.h)
+-AM_PATH_CPPUNIT(1.9.6)
+
+ AC_PROG_CXX
+