summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2017-03-09 18:37:31 +0100
committerxsmile2017-03-09 18:37:31 +0100
commitcd7471074678fbe3d67e8350a77f081416331237 (patch)
treef938207a6299f0405a512ed5a8872a7855f842c7
downloadaur-cd7471074678fbe3d67e8350a77f081416331237.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a4001d561d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Mar 9 17:34:01 UTC 2017
+pkgbase = libtorrent-ps
+ pkgdesc = BitTorrent library written in C++
+ pkgver = 0.13.6
+ pkgrel = 1
+ url = https://github.com/rakshasa/libtorrent
+ arch = any
+ license = GPL
+ depends = openssl
+ provides = libtorrent
+ conflicts = libtorrent
+ conflicts = libtorrent-git
+ conflicts = libtorrent-ipv6
+ conflicts = libtorrent-ps-git
+ conflicts = libtorrent-pyro
+ conflicts = libtorrent-pyro-git
+ source = https://github.com/rakshasa/libtorrent/archive/0.13.6.tar.gz
+ md5sums = 8c8eaa9fa03bd113967c68eea26493e7
+
+pkgname = libtorrent-ps
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a9bd76159bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: xsmile <sascha_r gmx de>
+
+_pkgname=libtorrent
+pkgname=libtorrent-ps
+pkgver=0.13.6
+pkgrel=1
+pkgdesc='BitTorrent library written in C++'
+url='https://github.com/rakshasa/libtorrent'
+license=('GPL')
+arch=('any')
+depends=('openssl')
+provides=('libtorrent')
+conflicts=('libtorrent' 'libtorrent-git' 'libtorrent-ipv6' 'libtorrent-ps-git' 'libtorrent-pyro' 'libtorrent-pyro-git')
+source=("https://github.com/rakshasa/$_pkgname/archive/$pkgver.tar.gz")
+md5sums=('8c8eaa9fa03bd113967c68eea26493e7')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
+ --disable-instrumentation
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}