summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-06-01 14:10:39 -0400
committerskydrome2015-06-01 14:10:39 -0400
commita45a67db4f0f6fc937e30876cd0d5405727e76b2 (patch)
treed20845478f1eb0456c0e89562fe6078965c9a02c
downloadaur-a45a67db4f0f6fc937e30876cd0d5405727e76b2.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD61
-rw-r--r--libtorrent-pyro.install9
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3981615feae6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libtorrent-pyro-git
+ pkgdesc = BitTorrent library written in C++ (git version)
+ pkgver = 20140703
+ pkgrel = 1
+ url = http://libtorrent.rakshasa.no
+ install = libtorrent-pyro.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cppunit
+ depends = openssl
+ provides = libtorrent
+ conflicts = libtorrent
+ conflicts = libtorrent-git
+ source = git://github.com/rakshasa/libtorrent.git#commit=HEAD
+ md5sums = SKIP
+
+pkgname = libtorrent-pyro-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..040861bc63bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: skydrome <skydrome@i2pmail.org>
+# Contributor: skydrome <skydrome@i2pmail.org>
+
+# Compile a debug build?
+_debug=n
+
+# Compile from a specific commit?
+#_commit=4202ad3 #0.13.3
+#_commit=51cd5ea #0.13.4
+_commit=HEAD
+
+# Add the following to your rtorrent.rc if your
+# filesystem supports the fallocate() function
+# system.file.allocate.set = yes
+[[ $(stat -Lfc %T /home) = @(ext4|xfs|btrfs) ]] &&
+ _falloc='--with-posix-fallocate'
+
+pkgname=libtorrent-pyro-git
+pkgver=20140703
+pkgrel=1
+pkgdesc='BitTorrent library written in C++ (git version)'
+url='http://libtorrent.rakshasa.no'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('openssl')
+makedepends=('git' 'cppunit')
+conflicts=('libtorrent' 'libtorrent-git')
+provides=('libtorrent')
+install=libtorrent-pyro.install
+
+[[ $_debug = 'n' ]] &&
+ _debug='--disable-debug' || options=(!strip)
+
+source=("git://github.com/rakshasa/libtorrent.git#commit=$_commit")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/libtorrent"
+ git log -1 --format="%cd" --date=short "$_commit" |tr -d -
+}
+
+prepare() {
+ cd "$srcdir/libtorrent"
+ #patch -Np1 -i "${startdir}/libtorrent.patch"
+
+ ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/libtorrent"
+ export CXXFLAGS+=" -std=c++11"
+
+ ./configure $_falloc $_debug \
+ --prefix=/usr
+
+ make
+}
+
+package() {
+ make -C "$srcdir/libtorrent" DESTDIR="$pkgdir" install
+}
diff --git a/libtorrent-pyro.install b/libtorrent-pyro.install
new file mode 100644
index 000000000000..9258a40bfffc
--- /dev/null
+++ b/libtorrent-pyro.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo
+ echo " If you set custom options in the PKGBUILD, do the same for the"
+ echo " rtorrent-pyro-git package"
+ echo
+}
+post_upgrade() {
+ post_install
+}