summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2022-04-16 20:02:27 +0500
committerHanabishi2022-04-16 20:02:27 +0500
commit56c25c2d754eac440fd4951250d0306b34c5730b (patch)
treecdc25e065548b8c4cd30b7e4a38aa59d1d9a746f
parentf52df11f0c3f0cbcd76c60228dc7750886765a32 (diff)
downloadaur-56c25c2d754eac440fd4951250d0306b34c5730b.tar.gz
New version
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD15
3 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c4bd4f61f4c..d9ac02432a3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libtorrent-rasterbar-1
pkgdesc = Open source C++ library implementing the BitTorrent protocol.
- pkgver = 1.2.15
+ pkgver = 1.2.16
pkgrel = 1
url = https://libtorrent.org/
arch = x86_64
@@ -11,10 +11,10 @@ pkgbase = libtorrent-rasterbar-1
makedepends = python-setuptools
depends = boost-libs
depends = openssl
- provides = libtorrent-rasterbar=1.2.15
+ provides = libtorrent-rasterbar=1.2.16
conflicts = libtorrent-rasterbar
options = !emptydirs
- source = libtorrent-rasterbar-1.2.15.tar.gz::https://github.com/arvidn/libtorrent/releases/download/v1.2.15/libtorrent-rasterbar-1.2.15.tar.gz
- sha256sums = c8ad8638684c0a903ebabc30490079e31b1a6a638da2adec5a8bef6a0e62214b
+ source = libtorrent-1.2.16.tar.gz::https://github.com/arvidn/libtorrent/archive/v1.2.16.tar.gz
+ sha256sums = 2ee435c3e2e6dd8825903230b41fbaf0741b7aed57094f2ca0e6214d89fef9d4
pkgname = libtorrent-rasterbar-1
diff --git a/.gitignore b/.gitignore
index 1065a34977f6..924dfb95c209 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,3 @@
pkg/
src/
-*.pkg.tar.*
-*.tar.gz
-*.tar.gz.* \ No newline at end of file
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 709d3fe29ea1..28d553bab404 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=libtorrent-rasterbar-1
-pkgver=1.2.15
+pkgver=1.2.16
pkgrel=1
pkgdesc="Open source C++ library implementing the BitTorrent protocol."
url="https://libtorrent.org/"
@@ -7,15 +7,16 @@ arch=('x86_64')
license=('BSD')
depends=('boost-libs' 'openssl')
makedepends=('boost' 'cmake' 'ninja' 'python-setuptools')
-provides=("libtorrent-rasterbar=${pkgver}")
-conflicts=('libtorrent-rasterbar')
+_name="${pkgname%-1}"
+provides=("${_name}=${pkgver}")
+conflicts=("${_name}")
options=('!emptydirs')
-_snapshot="libtorrent-rasterbar-${pkgver}"
-_archive="${_snapshot}.tar.gz"
+_repo="${_name%-rasterbar}"
+_snapshot="${_repo}-${pkgver}"
-source=("${_archive}::https://github.com/arvidn/libtorrent/releases/download/v${pkgver}/${_archive}")
-sha256sums=('c8ad8638684c0a903ebabc30490079e31b1a6a638da2adec5a8bef6a0e62214b')
+source=("${_snapshot}.tar.gz::https://github.com/arvidn/${_repo}/archive/v${pkgver}.tar.gz")
+sha256sums=('2ee435c3e2e6dd8825903230b41fbaf0741b7aed57094f2ca0e6214d89fef9d4')
build() {
cd "${srcdir}"