summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2022-01-17 01:28:14 +0500
committerHanabishi2022-01-17 01:28:14 +0500
commitedca25e78d31807c039b916b9649c2d6d09633f6 (patch)
tree6b1184afaa369df070344c18d59c4d71fd2117cc
downloadaur-edca25e78d31807c039b916b9649c2d6d09633f6.tar.gz
Init package
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7af589042cd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libtorrent-rasterbar-1
+ pkgdesc = A C++ BitTorrent library that aims to be a good alternative to all the other implementations around
+ pkgver = 1.2.15
+ pkgrel = 1
+ url = https://www.rasterbar.com/products/libtorrent/
+ arch = x86_64
+ license = BSD
+ makedepends = boost
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = python-setuptools
+ depends = boost-libs
+ depends = openssl
+ provides = libtorrent-rasterbar=1.2.15
+ conflicts = libtorrent-rasterbar
+ options = !emptydirs
+ source = libtorrent-rasterbar-1.2.15.tar.gz::https://github.com/arvidn/libtorrent/releases/download/v1.2.15/libtorrent-rasterbar-1.2.15.tar.gz
+ sha512sums = c409c53ec9c299a05b51ab61d7df1209803cbd6070f0a014dd6fb42c30f6f5230ea90848330f901c61816bc70901e618409acacc95bb0e5acb7f81211d001fa2
+
+pkgname = libtorrent-rasterbar-1
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1065a34977f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.pkg.tar.*
+*.tar.gz
+*.tar.gz.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e444c4c2c03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=libtorrent-rasterbar-1
+pkgver=1.2.15
+pkgrel=1
+pkgdesc="A C++ BitTorrent library that aims to be a good alternative to all the other implementations around"
+url="https://www.rasterbar.com/products/libtorrent/"
+arch=('x86_64')
+license=('BSD')
+depends=('boost-libs' 'openssl')
+makedepends=('boost' 'cmake' 'ninja' 'python-setuptools')
+provides=('libtorrent-rasterbar=1.2.15')
+conflicts=('libtorrent-rasterbar')
+options=('!emptydirs')
+
+_snapshot="libtorrent-rasterbar-${pkgver}"
+_archive="${_snapshot}.tar.gz"
+
+source=("${_archive}::https://github.com/arvidn/libtorrent/releases/download/v${pkgver}/${_archive}")
+sha512sums=('c409c53ec9c299a05b51ab61d7df1209803cbd6070f0a014dd6fb42c30f6f5230ea90848330f901c61816bc70901e618409acacc95bb0e5acb7f81211d001fa2')
+
+build() {
+ mkdir -p "${srcdir}/build" && cd "$_"
+
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -Dpython-bindings=ON \
+ -Dboost-python-module-name="python" \
+ -Dpython-egg-info=ON \
+ -GNinja "${srcdir}/${_snapshot}"
+
+ ninja
+}
+
+package() {
+ cd "${srcdir}/build"
+ DESTDIR="${pkgdir}" ninja install
+
+ cd "${srcdir}/${_snapshot}"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "COPYING"
+}