summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12016-11-11 11:37:57 +0800
committerChocobo12016-11-11 11:37:57 +0800
commit9835db82654709d10f22a07f7c4668d5a15b4aeb (patch)
treea278306e9e4a814d568562acbac270b596735226
parente1f10c33bb0e7b1d6c3188161d0a347c7dc54572 (diff)
downloadaur-9835db82654709d10f22a07f7c4668d5a15b4aeb.tar.gz
upgpkg: libtorrent-rasterbar-1_0-git 1.0.10.r9.ga166c3f-1
-rw-r--r--.SRCINFO4
-rw-r--r--Fix_out_of_srcdir_build.patch49
-rw-r--r--PKGBUILD9
3 files changed, 4 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4461af83726b..83928ecdfc60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libtorrent-rasterbar-1_0-git
pkgdesc = A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git branch RC_1_0)
- pkgver = 1.0.10.r7.geec6957
+ pkgver = 1.0.10.r9.ga166c3f
pkgrel = 1
url = http://www.libtorrent.org/
arch = i686
@@ -13,9 +13,7 @@ pkgbase = libtorrent-rasterbar-1_0-git
provides = libtorrent-rasterbar
conflicts = libtorrent-rasterbar
source = git+https://github.com/arvidn/libtorrent.git#branch=RC_1_0
- source = Fix_out_of_srcdir_build.patch
sha256sums = SKIP
- sha256sums = e4dfe4363eb5f196363d3b477377046d6241c7e8277d475dc8f74ef612d77850
pkgname = libtorrent-rasterbar-1_0-git
diff --git a/Fix_out_of_srcdir_build.patch b/Fix_out_of_srcdir_build.patch
deleted file mode 100644
index d7bb176a2189..000000000000
--- a/Fix_out_of_srcdir_build.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From ef66f59bb9de005d87f2be17bb4626eb128ea03c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?D=C4=81vis?= <davispuh@gmail.com>
-Date: Mon, 3 Aug 2015 18:14:06 +0300
-Subject: [PATCH] Fix out of srcdir build
-
----
- bindings/python/Makefile.am | 6 +++---
- bindings/python/setup.py | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
-index b7e6a98..c909ac5 100644
---- a/bindings/python/Makefile.am
-+++ b/bindings/python/Makefile.am
-@@ -33,15 +33,15 @@ EXTRA_DIST = \
- if ENABLE_PYTHON_BINDING
-
- all-local:
-- $(PYTHON) setup.py build
-+ $(PYTHON) $(srcdir)/setup.py build
-
- install-exec-local:
-- $(PYTHON) setup.py install @PYTHON_INSTALL_PARAMS@
-+ $(PYTHON) $(srcdir)/setup.py install @PYTHON_INSTALL_PARAMS@
-
- uninstall-local:
- rm -rf $(DESTDIR)$(libdir)/python*/*-packages/*libtorrent*
-
- clean-local:
-- $(PYTHON) setup.py clean --all
-+ $(PYTHON) $(srcdir)/setup.py clean --all
-
- endif
-diff --git a/bindings/python/setup.py b/bindings/python/setup.py
-index fb857f2..170e73c 100644
---- a/bindings/python/setup.py
-+++ b/bindings/python/setup.py
-@@ -95,7 +95,7 @@ else:
- flag for flag in get_config_var('OPT').split() if flag != '-Wstrict-prototypes')
-
- source_list = os.listdir(os.path.join(os.path.dirname(__file__), "src"))
-- source_list = [os.path.join("src", s) for s in source_list if s.endswith(".cpp")]
-+ source_list = [os.path.abspath(os.path.join(os.path.dirname(__file__), "src", s)) for s in source_list if s.endswith(".cpp")]
-
- ext = [Extension('libtorrent',
- sources = source_list,
---
-2.10.0.windows.1
-
diff --git a/PKGBUILD b/PKGBUILD
index fcc102d689be..a2eb7af148c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1
pkgname=libtorrent-rasterbar-1_0-git
-pkgver=1.0.10.r7.geec6957
+pkgver=1.0.10.r9.ga166c3f
pkgrel=1
pkgdesc='A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git branch RC_1_0)'
url='http://www.libtorrent.org/'
@@ -11,10 +11,8 @@ depends=('boost-libs')
makedepends=('boost' 'python2' 'python')
provides=('libtorrent-rasterbar')
conflicts=('libtorrent-rasterbar')
-source=('git+https://github.com/arvidn/libtorrent.git#branch=RC_1_0'
- Fix_out_of_srcdir_build.patch)
-sha256sums=('SKIP'
- 'e4dfe4363eb5f196363d3b477377046d6241c7e8277d475dc8f74ef612d77850')
+source=('git+https://github.com/arvidn/libtorrent.git#branch=RC_1_0')
+sha256sums=('SKIP')
pkgver() {
@@ -27,7 +25,6 @@ prepare() {
mkdir -p py2 py3
cd "libtorrent"
- patch -p1 -i ../Fix_out_of_srcdir_build.patch
./autotool.sh
}