summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-26 11:01:10 +0800
committerChocobo12017-08-26 11:01:10 +0800
commitdfd983748a30ee6940a64c106f2a6f3cb0dea24a (patch)
tree4463c90afab1d48b2923aa8c06aca8cd7fe750bd
parent5b0a544a3f5d6983bf16e4aba92f0a59fee56dd1 (diff)
downloadaur-dfd983748a30ee6940a64c106f2a6f3cb0dea24a.tar.gz
upgpkg: libtorrent-rasterbar-1_0-git 1.0.11.r7.gc074e8788-2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b2eb86e3904..51260ca23484 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libtorrent-rasterbar-1_0-git
pkgdesc = A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git branch RC_1_0)
pkgver = 1.0.11.r7.gc074e8788
- pkgrel = 1
+ pkgrel = 2
url = http://www.libtorrent.org/
arch = i686
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = libtorrent-rasterbar-1_0-git
provides = libtorrent-rasterbar
conflicts = libtorrent-rasterbar
options = staticlibs
+ options = !strip
source = git+https://github.com/arvidn/libtorrent.git#branch=RC_1_0
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3ef3afc6d9ca..815cae714e35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libtorrent-rasterbar-1_0-git
pkgver=1.0.11.r7.gc074e8788
-pkgrel=1
+pkgrel=2
pkgdesc="A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git branch RC_1_0)"
arch=('i686' 'x86_64')
url="http://www.libtorrent.org/"
@@ -11,22 +11,25 @@ depends=('boost-libs')
makedepends=('git' 'boost' 'python2' 'python')
provides=('libtorrent-rasterbar')
conflicts=('libtorrent-rasterbar')
-options=('staticlibs')
+options=('staticlibs' '!strip')
source=('git+https://github.com/arvidn/libtorrent.git#branch=RC_1_0')
sha256sums=('SKIP')
-prepare() {
- mkdir -p py2 py3
+pkgver() {
cd "libtorrent"
- ./autotool.sh
+ git describe --long --tags | sed 's/^[A-Za-z]*-//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
}
-pkgver() {
+build() {
cd "libtorrent"
+ ./autotool.sh
- git describe --long --tags | sed 's/^[A-Za-z]*-//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
+ cd "$srcdir"
+ mkdir -p "py2" "py3"
+ _build 2
+ _build 3
}
_build() (
@@ -40,19 +43,14 @@ _build() (
CXXFLAGS="$CXXFLAGS -std=c++11" \
PYTHON="/usr/bin/python$1" \
../libtorrent/configure \
- --prefix=/usr \
- --enable-python-binding \
+ --prefix="/usr" \
--with-libiconv \
+ --enable-python-binding \
--with-boost-python="$_boost"
make
)
-build() {
- _build 2
- _build 3
-}
-
package() {
make -C py2 DESTDIR="$pkgdir" install
make -C py3 DESTDIR="$pkgdir" install