summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-11-10 22:06:24 +0800
committerChocobo12018-11-11 15:23:25 +0800
commit89bc62eb68c800804ab086839a0f1456835326f4 (patch)
treee02be36e8db5234c6c18678369d50ebffd7d9f95
parent31425640f32c29af744439ff966217ba37dca3e0 (diff)
downloadaur-89bc62eb68c800804ab086839a0f1456835326f4.tar.gz
upgpkg: libtorrent-rasterbar-1_1-git 1.1.10.r15.ga2a10e9be-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
2 files changed, 15 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f34beb99a496..9dfd9e8cb690 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libtorrent-rasterbar-1_1-git
pkgdesc = A feature complete C++ bittorrent library (git branch RC_1_1)
- pkgver = 1.1.7.r16.gdc28c9655
+ pkgver = 1.1.10.r15.ga2a10e9be
pkgrel = 1
url = https://www.libtorrent.org/
arch = i686
@@ -8,12 +8,14 @@ pkgbase = libtorrent-rasterbar-1_1-git
license = BSD
makedepends = git
makedepends = boost
+ makedepends = cmake
makedepends = python
+ makedepends = python-setuptools
makedepends = python2
+ makedepends = python2-setuptools
depends = boost-libs
provides = libtorrent-rasterbar
conflicts = libtorrent-rasterbar
- options = staticlibs
options = !strip
source = git+https://github.com/arvidn/libtorrent.git#branch=RC_1_1
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e767397842e0..1f1e01e5e655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libtorrent-rasterbar-1_1-git
-pkgver=1.1.7.r16.gdc28c9655
+pkgver=1.1.10.r15.ga2a10e9be
pkgrel=1
pkgdesc="A feature complete C++ bittorrent library (git branch RC_1_1)"
arch=('i686' 'x86_64')
url="https://www.libtorrent.org/"
license=('BSD')
depends=('boost-libs')
-makedepends=('git' 'boost' 'python' 'python2')
+makedepends=('git' 'boost' 'cmake' 'python' 'python-setuptools' 'python2' 'python2-setuptools')
provides=('libtorrent-rasterbar')
conflicts=('libtorrent-rasterbar')
-options=('staticlibs' '!strip')
+options=('!strip')
source=('git+https://github.com/arvidn/libtorrent.git#branch=RC_1_1')
sha256sums=('SKIP')
@@ -23,10 +23,8 @@ pkgver() {
}
build() {
- cd "libtorrent"
- ./autotool.sh
-
cd "$srcdir"
+
mkdir -p "py2" "py3"
_build 2
_build 3
@@ -35,19 +33,13 @@ build() {
_build() (
cd "py$1"
- # https://bugs.archlinux.org/task/50745
- _boost="boost_python"
- if [ $1 = "3" ]; then _boost="boost_python3"; fi
-
- # https://github.com/qbittorrent/qBittorrent/issues/5265#issuecomment-220007436
- CXXFLAGS="$CXXFLAGS -std=c++11" \
- PYTHON="/usr/bin/python$1" \
- ../libtorrent/configure \
- --prefix="/usr" \
- --with-libiconv \
- --enable-python-binding \
- --with-boost-python="$_boost"
-
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -Dpython-bindings=ON \
+ -DPYTHON_EXECUTABLE="/usr/bin/python$1" \
+ "../libtorrent"
make
)