summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-08-13 01:31:59 +0800
committerChocobo12020-08-13 01:33:45 +0800
commitfe39965f59ad9a0c6bf04464df7f853634d8dfbb (patch)
tree2950aec951efc902b600327f73f72cf01cee8769
downloadaur-fe39965f59ad9a0c6bf04464df7f853634d8dfbb.tar.gz
newpkg: libtorrent-rasterbar-2_0-git r16454.gfdf377a33-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dfc12d7139c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libtorrent-rasterbar-2_0-git
+ pkgdesc = A feature complete C++ bittorrent library (git branch RC_2_0)
+ pkgver = r16454.gfdf377a33
+ pkgrel = 1
+ url = https://www.libtorrent.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = boost
+ makedepends = cmake
+ makedepends = python
+ makedepends = python-setuptools
+ depends = boost-libs
+ provides = libtorrent-rasterbar
+ conflicts = libtorrent-rasterbar
+ options = !strip
+ source = git+https://github.com/arvidn/libtorrent.git#branch=RC_2_0
+ sha256sums = SKIP
+
+pkgname = libtorrent-rasterbar-2_0-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f6bda4e621d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libtorrent-rasterbar-2_0-git
+pkgver=r16454.gfdf377a33
+pkgrel=1
+pkgdesc="A feature complete C++ bittorrent library (git branch RC_2_0)"
+arch=('i686' 'x86_64')
+url="https://www.libtorrent.org/"
+license=('BSD')
+depends=('boost-libs')
+makedepends=('git' 'boost' 'cmake' 'python' 'python-setuptools')
+provides=('libtorrent-rasterbar')
+conflicts=('libtorrent-rasterbar')
+options=('!strip')
+source=('git+https://github.com/arvidn/libtorrent.git#branch=RC_2_0')
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "libtorrent"
+
+ git submodule update --init --recursive
+}
+
+pkgver() {
+ cd "libtorrent"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "libtorrent"
+
+ mkdir -p "_build" && cd "_build"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -Dpython-bindings=ON \
+ -Dboost-python-module-name="python" \
+ "../"
+ make
+}
+
+package() {
+ cd "libtorrent"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/libtorrent-rasterbar"
+}