summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-07-18 23:12:58 +0000
committerDaniel Bermond2020-07-18 23:12:58 +0000
commita7bd5711df094a2aab3daaec99be2de873685ca7 (patch)
tree0848f68985cceeb9137736190f1ebbad6a71663d
parente9c80b1c36e3d36b48a4bfddce9313fb7b77be83 (diff)
downloadaur-a7bd5711df094a2aab3daaec99be2de873685ca7.tar.gz
Fix pkgver and default branch. Add new git submodules.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1a91cd7f0bf..c0b0384bfd59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libtorrent-rasterbar-git
pkgdesc = A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git version)
- pkgver = 1.2.3.r319.g9dfff3677
+ pkgver = 2.0.0.RC.r584.ge0d9d7791
pkgrel = 1
url = https://www.rasterbar.com/products/libtorrent/
arch = x86_64
@@ -17,9 +17,15 @@ pkgbase = libtorrent-rasterbar-git
optdepends = python: for python3 bindings
provides = libtorrent-rasterbar
conflicts = libtorrent-rasterbar
- source = libtorrent-rasterbar::git+https://github.com/arvidn/libtorrent.git
+ source = libtorrent-rasterbar::git+https://github.com/arvidn/libtorrent.git#branch=master
source = git+https://github.com/arvidn/libsimulator.git
source = git+https://github.com/arvidn/try_signal.git
+ source = git+https://github.com/paullouisageneau/boost-asio-gnutls.git
+ source = git+https://github.com/paullouisageneau/libdatachannel.git
+ source = json-vinniefalco::git+https://github.com/vinniefalco/json.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 924a5ca57a0c..7ba8a48e599d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer : Daniel Bermond <dbermond@archlinux.org>
pkgname=libtorrent-rasterbar-git
-pkgver=1.2.3.r319.g9dfff3677
+pkgver=2.0.0.RC.r584.ge0d9d7791
pkgrel=1
pkgdesc='A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git version)'
url='https://www.rasterbar.com/products/libtorrent/'
@@ -14,24 +14,31 @@ optdepends=('boost-libs: for python bindings'
'python: for python3 bindings')
provides=('libtorrent-rasterbar')
conflicts=('libtorrent-rasterbar')
-source=('libtorrent-rasterbar'::'git+https://github.com/arvidn/libtorrent.git'
+source=('libtorrent-rasterbar'::'git+https://github.com/arvidn/libtorrent.git#branch=master'
'git+https://github.com/arvidn/libsimulator.git'
- 'git+https://github.com/arvidn/try_signal.git')
+ 'git+https://github.com/arvidn/try_signal.git'
+ 'git+https://github.com/paullouisageneau/boost-asio-gnutls.git'
+ 'git+https://github.com/paullouisageneau/libdatachannel.git'
+ 'json-vinniefalco'::'git+https://github.com/vinniefalco/json.git')
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
- cd libtorrent-rasterbar
- git submodule init
- git config --local "submodule.simulation/libsimulator.url" "${srcdir}/libsimulator"
- git config --local "submodule.deps/try_signal.url" "${srcdir}/try_signal"
- git submodule update
+ git -C libtorrent-rasterbar submodule init
+ git -C libtorrent-rasterbar config --local "submodule.simulation/libsimulator.url" "${srcdir}/libsimulator"
+ git -C libtorrent-rasterbar config --local "submodule.deps/try_signal.url" "${srcdir}/try_signal"
+ git -C libtorrent-rasterbar config --local "submodule.deps/asio-gnutls.url" "${srcdir}/boost-asio-gnutls"
+ git -C libtorrent-rasterbar config --local "submodule.deps/libdatachannel.url" "${srcdir}/libdatachannel"
+ git -C libtorrent-rasterbar config --local "submodule.deps/json.url" "${srcdir}/json-vinniefalco"
+ git -C libtorrent-rasterbar submodule update
}
pkgver() {
- cd libtorrent-rasterbar
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g;s/^libtorrent\.//'
+ git -C libtorrent-rasterbar describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g;s/^libtorrent.//'
}
_build_common() {
@@ -59,7 +66,6 @@ _build_common() {
build() {
local _py2ver
local _pyver
-
_py2ver="$(python2 -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"
_pyver="$(python -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"
@@ -70,7 +76,6 @@ build() {
package() {
local _py2ver
local _pyver
-
_py2ver="$(python2 -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"
_pyver="$(python -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"