summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2019-02-08 15:30:30 +0100
committerGianluca Boiano2019-02-08 15:30:30 +0100
commit7d05014f0bfd79e11f4ece95da1da0608d25ec60 (patch)
treec59abbf7baffcf5718fdb44792ecace401a752b3
parentb3ca5f91a454812a17b6d01b1e5e7f7c4ddb1b0d (diff)
downloadaur-7d05014f0bfd79e11f4ece95da1da0608d25ec60.tar.gz
libtpms: 0.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1618c723f986..f91d41d211ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Jan 7 15:23:12 UTC 2016
pkgbase = libtpms
pkgdesc = The libtpms library provides software emulation of a Trusted Platform Module (TPM 1.2)
- pkgver = 0.5.2.1
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/stefanberger/libtpms
arch = i686
@@ -13,8 +11,8 @@ pkgbase = libtpms
depends = openssl
depends = zlib
provides = libtpms
- source = git+https://github.com/stefanberger/libtpms.git#tag=v0.5.2.1
- sha1sums = SKIP
+ source = https://github.com/stefanberger/libtpms/archive/v0.6.0.tar.gz
+ md5sums = c9301e08d50bc07dab62804261be44d5
pkgname = libtpms
diff --git a/PKGBUILD b/PKGBUILD
index 639a60e43097..3adc66d56052 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: robertfoster
pkgname=libtpms
-pkgver=0.5.2.1
+pkgver=0.6.0
pkgrel=1
pkgdesc="The libtpms library provides software emulation of a Trusted Platform Module (TPM 1.2)"
arch=('i686' 'x86_64')
@@ -10,20 +10,17 @@ license=(unknown)
depends=('openssl' 'zlib')
makedepends=('automake' 'autoconf')
provides=('libtpms')
-source=("git+https://github.com/stefanberger/libtpms.git#tag=v${pkgver}")
-sha1sums=('SKIP')
-_gitname=libtpms
+source=("https://github.com/stefanberger/libtpms/archive/v${pkgver}.tar.gz")
build() {
- cd $_gitname
- ./bootstrap.sh
- ./configure --prefix=/usr --with-openssl
- make
+ cd "$pkgname-$pkgver"
+ ./autogen.sh --with-tpm2 --with-openssl --prefix=/usr
+ make all
}
package() {
- cd $_gitname
- make DESTDIR="${pkgdir}" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" install
}
-# vim:set ts=2 sw=2 et:
+md5sums=('c9301e08d50bc07dab62804261be44d5')