summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Nehls2016-01-07 16:24:10 +0100
committerRobin Nehls2016-01-07 16:24:10 +0100
commit9fc63fc7eec5088d189b4553c834147ad3fe7482 (patch)
tree4af26264c556abfffaa7999e43914cd3bd4c15a2
downloadaur-9fc63fc7eec5088d189b4553c834147ad3fe7482.tar.gz
initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1618c723f986
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Jan 7 15:23:12 UTC 2016
+pkgbase = libtpms
+ pkgdesc = The libtpms library provides software emulation of a Trusted Platform Module (TPM 1.2)
+ pkgver = 0.5.2.1
+ pkgrel = 1
+ url = https://github.com/stefanberger/libtpms
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = automake
+ makedepends = autoconf
+ depends = openssl
+ depends = zlib
+ provides = libtpms
+ source = git+https://github.com/stefanberger/libtpms.git#tag=v0.5.2.1
+ sha1sums = SKIP
+
+pkgname = libtpms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3ca31252d63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Robin Nehls <aur@manol.is>
+
+pkgname=libtpms
+pkgver=0.5.2.1
+pkgrel=1
+pkgdesc="The libtpms library provides software emulation of a Trusted Platform Module (TPM 1.2)"
+arch=('i686' 'x86_64')
+url="https://github.com/stefanberger/libtpms"
+license=(unknown)
+depends=('openssl' 'zlib')
+makedepends=('automake' 'autoconf')
+provides=('libtpms')
+source=("git+https://github.com/stefanberger/libtpms.git#tag=v${pkgver}")
+sha1sums=('SKIP')
+_gitname=libtpms
+
+build() {
+ cd $_gitname
+ ./bootstrap.sh
+ ./configure --prefix=/usr --with-openssl
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: