summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorotreblan2020-04-14 17:01:13 -0500
committerotreblan2020-04-14 17:01:13 -0500
commit8120c20b2bc380c63a9e1c560808fe2f4dc0efb8 (patch)
treee431984641d6ed2bc0a458cf57320235e810d61e
parent4ca1024201d9bf69e6e99fd1d8a33547a878cf1f (diff)
downloadaur-8120c20b2bc380c63a9e1c560808fe2f4dc0efb8.tar.gz
Add gtest as checkdependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d7ac994f4ff..1f9dfc6e508f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = libtree-git
pkgdesc = ldd as a tree with an option to bundle dependencies into a single folder
- pkgver = 1.0.3.r0.ga48bb32
+ pkgver = 1.0.4.r8.g02ee2b1
pkgrel = 1
url = https://github.com/haampie/libtree
arch = x86_64
license = MIT
+ checkdepends = gtest
makedepends = git
makedepends = cmake
makedepends = cxxopts
diff --git a/PKGBUILD b/PKGBUILD
index 53deeb43696b..a1e27582cebf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Otreblan <otreblain@gmail.com>
pkgname=libtree-git
-pkgver=1.0.3.r0.ga48bb32
+pkgver=1.0.4.r8.g02ee2b1
pkgrel=1
pkgdesc="ldd as a tree with an option to bundle dependencies into a single folder "
arch=('x86_64')
@@ -12,6 +12,7 @@ makedepends=('git' 'cmake' 'cxxopts' 'termcolor' 'elfio')
optdepends=('binutils: For the --strip option'
'chrpath: For the --chrpath option'
)
+checkdepends=('gtest')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+$url.git")
@@ -42,6 +43,12 @@ build() {
make
}
+check() {
+ cd "${pkgname%-git}/build" || exit 1
+
+ make test
+}
+
package() {
cd "${pkgname%-git}/build" || exit 1