summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2015-08-09 16:52:08 +0200
committerLucas Werkmeister2015-08-09 17:00:50 +0200
commita525879fce751b4c36a06d8e4a2261153ae1cc16 (patch)
tree0d0ad23ce283690abe32e89a92b683074d0519de
downloadaur-a525879fce751b4c36a06d8e4a2261153ae1cc16.tar.gz
Initial commit
PKGBUILD based on the PKGBUILDs of turpial and libturpial-git.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70ea669597ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libturpial
+ pkgdesc = A library that handles multiple microblogging protocols.
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = http://turpial.org.ve/
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2-oauth
+ depends = python2-requests
+ depends = python2-simplejson
+ source = http://files.turpial.org.ve/sources/stable/libturpial-1.7.0.tar.gz
+ sha1sums = eca4870ceeda43865136c92056205b146ab88ffb
+
+pkgname = libturpial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e069865e108d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Louis des Landes <psyker7 at gmail dot com>
+
+pkgname=libturpial
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="A library that handles multiple microblogging protocols."
+arch=(any)
+url=http://turpial.org.ve/
+license=(GPL3)
+depends=(python2-oauth python2-requests python2-simplejson)
+makedepends=(git python2-setuptools)
+source=(http://files.turpial.org.ve/sources/stable/$pkgname-$pkgver.tar.gz)
+sha1sums=(eca4870ceeda43865136c92056205b146ab88ffb) # ${source[0]}.sha1sum
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 || return 1
+ rm "$pkgdir"/usr/{AUTHORS,COPYING,ChangeLog}
+}