summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2020-07-14 16:08:14 +1000
committerVictor Tran2020-07-14 16:08:14 +1000
commita1250512432665ffb8fa99233a0130522d594c62 (patch)
treeb11f048bcb9c8812e34003be62a9752b5b36c27e
downloadaur-a1250512432665ffb8fa99233a0130522d594c62.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d9acdbf1536
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libtwebservices
+ pkgdesc = Common libraries for the- apps to communicate with web APIs
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/vicr123/libtwebservices
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ depends = the-libs
+ depends = qt5-base
+ source = libtwebservices-0.1::https://github.com/vicr123/libtwebservices/archive/v0.1.tar.gz
+ sha256sums = 0f37dba2524acab9a7e813f0229d607801f4ec442b4fadf6ff7681c3647f167b
+
+pkgname = libtwebservices
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d475d0993d62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=libtwebservices
+pkgver=0.1
+pkgrel=1
+pkgdesc="Common libraries for the- apps to communicate with web APIs"
+arch=("x86_64")
+url="https://github.com/vicr123/libtwebservices"
+license=('GPL3')
+depends=('the-libs' 'qt5-base')
+makedepends=('qt5-tools')
+source=("$pkgname-$pkgver"::"https://github.com/vicr123/libtwebservices/archive/v0.1.tar.gz")
+sha256sums=('0f37dba2524acab9a7e813f0229d607801f4ec442b4fadf6ff7681c3647f167b')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install INSTALL_ROOT=$pkgdir
+}