summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormisson200002019-01-02 20:17:24 -0800
committermisson200002019-01-02 20:17:24 -0800
commitcdaff25ea7c9dfc34f7ecd3e195f678d5ffc8b7b (patch)
tree2122728ea0639b914fb89752cebbc2f8cb314145
downloadaur-cdaff25ea7c9dfc34f7ecd3e195f678d5ffc8b7b.tar.gz
Initial commit (v1.0.0)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5950a5627dca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libtwili
+ pkgdesc = Small twili IO library
+ pkgver = 1.0.0.r0.g3a061af
+ pkgrel = 1
+ url = https://github.com/misson20000/twili-libnx
+ arch = any
+ license = ISC
+ makedepends = devkitpro-pkgbuild-helpers
+ options = !strip
+ options = staticlibs
+ source = git+https://github.com/misson20000/twili-libnx.git
+ sha256sums = SKIP
+
+pkgname = libtwili
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a842ba50b80c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: misson20000 <xenotoad@xenotoad.net>
+
+pkgname=libtwili
+pkgver=1.0.0.r0.g3a061af
+pkgrel=1
+pkgdesc='Small twili IO library'
+arch=('any')
+url='https://github.com/misson20000/twili-libnx'
+license=(ISC)
+options=(!strip staticlibs)
+makedepends=('devkitpro-pkgbuild-helpers')
+source=("git+https://github.com/misson20000/twili-libnx.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/twili-libnx"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/twili-libnx"
+
+ make
+}
+
+package() {
+ cd "$srcdir/twili-libnx"
+
+ source /opt/devkitpro/devkita64.sh
+ source /opt/devkitpro/switchvars.sh
+
+ make DESTDIR="$pkgdir"${PORTLIBS_PREFIX} install
+}